locked
Can't connect to 300Mbps 2.4GHz 802.11n wifi? Possible fix here

    General discussion

  • Upgraded from Win 7 Pro to Win 8 Dev Preview on my laptop and noticed my home wifi was no longer working.  Still worked fine on my phone's wifi hotspot but not with my home router (both 2.4GHz 802.11n with WPA-PSK2 AES).  After much fiddling the issue seems to be 300Mbps mode (aka 40MHz wide channels) on my router - if I type in the password (on my laptop) when the router is in this mode it immediately tells me it is unable to connect.  If I switch the router into 130Mbps mode (20MHz wide channels) the laptop actually tries to connect for a few seconds and eventually succeeds.  Then it is possible to switch the router back to 300Mbps mode (full speed confirmed working on the laptop by checking the wireless network connection status) and everything works fine.

    My laptop uses an Atheros AR5B97 to connect to my Netgear WNDR3700.  Tried both the Atheros drivers that came with Win8 (3.0.0.37) as well as the ones that I used when it had Win7 (9.0.0.202).  Also tried various tweaks like different SSIDs/passwords/encryption levels  - the only thing that helped was turning security off. Worked perfectly fine under Win7 and with all my other wireless devices.

    I reported it with the feedback tool but thought I would post in case anyone is having a similar issue - it took a while to figure out and was definitely going to be a deal-breaker for running the preview on my laptop.


    • Edited by poisonsnak Sunday, January 22, 2012 2:18 AM added channel width info
    Sunday, January 22, 2012 2:15 AM

All replies

  • Hello poisonsnak,

    You might also see if you have the latest upgrade to the firmware on your router.

    That might be helpful in getting connected.


    Thanks,
    Marilyn
    Sunday, January 29, 2012 10:12 PM
    Moderator