locked
Response.Redirect not working right in IE9 RRS feed

  • Question

  • User-854744733 posted

    We have public home page. when user without authentication clicks on a link A it initally redirects to Page A and sees if the user is not  logged in redirects to login page but also creates a Session variable . upon successful validation the user need to redirect to the Page A depending upon a Session variable previously created. the code is working perfectly for all the browsers except in IE9 any idea why? we use forms authentication

    Thanks,

    Thursday, February 28, 2013 2:50 PM

Answers

  • User-854744733 posted

    Thanks for all your replies and effort I figured it out. it has something to do with the user cache,. Internet Explorer 9 (IE9) permanently caches redirects even if they are changed on the server. 

    but upon testing in InPrivate Browsing where it doesnt store any cache. it resolved and you also 

    1. you need to clear your browser history and cache 

    2. Close and restart Internet Explorer 

    Thank you every one.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, March 1, 2013 4:43 PM

All replies

  • User-760709272 posted

    How is it not working?

    Friday, March 1, 2013 8:32 AM
  • User220175380 posted

    Hi,

    Use Server.transfer("mail.aspx") method

    Friday, March 1, 2013 8:37 AM
  • User281315223 posted

    Could you post some of the code where you are using Response.Redirect? It is likely some minor issue, but I couldn't imagine why it wouldn't work correctly within a single browser unless there are some issues with how it is being called. (What is occuring when it doesn't work correctly?)

    Friday, March 1, 2013 8:38 AM
  • User-854744733 posted

    Thanks for all your replies and effort I figured it out. it has something to do with the user cache,. Internet Explorer 9 (IE9) permanently caches redirects even if they are changed on the server. 

    but upon testing in InPrivate Browsing where it doesnt store any cache. it resolved and you also 

    1. you need to clear your browser history and cache 

    2. Close and restart Internet Explorer 

    Thank you every one.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, March 1, 2013 4:43 PM