none
Thumbnail Generation for Powerpoint using open xml RRS feed

  • Question

  • Hi,

    We are creating a presentation based on a template with one empty slide. A thumbnail gets created. On adding a new slide with some contant and deleting the first slide, the thumbnail does not get regenerated for the current first slide. Is this the expected behavior in open xml. Is there any solution or workaround ? Any help will be highly appreciated.

    Thanks,

    Regards,

    Keerthiga

    Thursday, October 25, 2012 2:10 PM

All replies

  • Hi Keerthiga,

    Thanks for posting in the MSDN Forum.

    It's based on my experience that your goal is hard to approach. The thumbnail which you mentioned is a kind of function of PowerPoint. It has nothing set in Document format. It will read the Presentation's content and generate it automatic.

    Have a good day,

    Tom


    Tom Xu [MSFT]
    MSDN Community Support | Feedback to us

    Friday, October 26, 2012 2:23 AM
    Moderator
  • Thanks for your reply Tom.

    The problem is while generating the presentation via open xml, it does not seem to generate the thumbnail automatically.

    Friday, October 26, 2012 6:23 AM
  • Hi Keerthiga,

    Would you please show your code which generate presentation for further research?

    Have a good day,

    Tom


    Tom Xu [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, October 30, 2012 5:56 AM
    Moderator
  • Hi Keerthinga,

    I will involve some experts into you issue to see whether they can help you out, there might be some time delay, thanks for your patience.

    Have a good day,

    Tom


    Tom Xu [MSFT]
    MSDN Community Support | Feedback to us


    Wednesday, October 31, 2012 7:36 AM
    Moderator
  • Hi Tom,

    Thanks for the effort. For now, we have decided to go with an approach using office object model but would love to hear about any findings.

    Thanks again and really appreciate all the help.

    Regards,

    Keerthiga Vishnuram

    Friday, November 2, 2012 6:42 AM
  • Hi Keerthiga,

    OK, I know. However I think your issue might help other community members, I will post my solution here if I found it.

    Have a good day,

    Tom


    Tom Xu [MSFT]
    MSDN Community Support | Feedback to us

    Monday, November 5, 2012 5:09 AM
    Moderator
  • Hello Keerthiga,

    The thumbnail images are generated by PowerPoint. Open XML SDK cannot generate an image. It can only add an existing image.

    By default, when you save a presentation, PowerPoint will generate and append a thumbnail image to the presentation. The template that you have, already contains a thumbnail which is usually the image of the first slide.

    When you delete the first slide using Open XML SDK, it just removes the first slide, its contents and the references. Open XML SDK cannot regenerate a new thumbnail for the new slide.

    If you have somehow generated an image, you can set the image as thumbnail through ThumbnailPart using Open XML SDK.

    Thanks,

    Sreerenj G Nair

    Wednesday, November 14, 2012 1:35 PM