none
Migrated 4.5 web application to 4.7.2 framework but not supporting TLS1.3 RRS feed

  • Question

  • Hi Team ,

    Migrated 4.5 web application to 4.7.2 framework but not supporting TLS1.3 , could you please suggest is support available for TLS 1.3

    If yes please share implementation details 

    Thursday, January 16, 2020 4:48 AM

All replies

  • FYI this migration is done from visual studio 4.5 framework to 4.7.2 framework

    please let us know if you require any info

    Thursday, January 16, 2020 4:49 AM
  • Hi 000rakesh,

    Thank you for posting here.

    .NET Core 3.0 now takes advantage of TLS 1.3 support in OpenSSL 1.1.1, but only for Linux.

    What's new in .NET Core 3.0

    And as far as I know, Microsoft hasn't recently announced to implement TLS 1.3.

    Best Regards,

    Timon


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, January 16, 2020 7:13 AM
  • Starting with .NET 4.6.2 (or so) .NET uses the default TLS configuration defined by Windows. While it doesn't technically expose TLS 1.3, in theory it'll use it if Windows is configured for it. You just need to make sure Windows is configured. For that you'll need to google how to enable it. Note though that it is a handshaking protocol so both the client and server must be using TLS 1.3 before it'll use that protocol. The current default is TLS 1.2 so unless you have your own service you probably will see TLS 1.2 being used.

    Michael Taylor http://www.michaeltaylorp3.net

    Thursday, January 16, 2020 4:28 PM
    Moderator