locked
"Operation Timed Out" error in IIS 8.5 RRS feed

  • Question

  • User-234026806 posted

    Hi There;

    I have a basic MVC web application. I have a personel computer and I have installed Windows Server 2012 and IIS 8.5 on it. When I write the IP address of the server to my browser, I can see the IIS wellcome screen. I create a sample web site and deploy it to server. When I reach the server,  I am getting 

    "500 - Internal server error.
    There is a problem with the resource you are looking for, and it cannot be displayed."

    error. When I log in to server and browse it locally, I am getting "Operation timed out" error. How can I resolve the issue? Thanks in advance.

    Thursday, July 20, 2017 11:17 AM

Answers

  • User1771544211 posted

    Hi varoulscuprens,

    This is the view when I try to reach the web site from server via 127.0.0.1:  (with edited hosts file)

    https://drive.google.com/open?id=0ByHTCWhitIBPS0ZPVlFQUGx0MnM

    In this condition, you are able to connect to the server, but the page you request is not found(404 error). So you can try access the specific page like http://127.0.0.1/page.html to see if it works. If it works, means that the IIS is working but you are missing some configurations.

    When you only type the http://127.0.0.1/ the IIS will check if there are any page match the default documents settings, it there is any default document, IIS will auto display the default page. Otherwise, it will return the 404 error. For more about the IIS default document settings, please check the following link.

    https://technet.microsoft.com/en-us/library/cc771439(v=ws.10).aspx

    This is the view when I try to reach the web site from client (when I run the web site)

    https://drive.google.com/open?id=0ByHTCWhitIBPU19nUTdyZGNIUEk

    The 500 error indicates the there is some error on the server side, to view the detailed error message remotely, please add the code into your web.config file.

    <configuration>
      <system.web>
        <customErrors mode="Off" />
      </system.web>
    
      <system.webServer>
        <httpErrors errorMode="Detailed" />
      </system.webServer>
    </configuration>

    Best Regards,

    Jean

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, July 24, 2017 6:37 AM

All replies

  • User753101303 posted

    Hi,

    Try to check the Windows event log or use https://docs.microsoft.com/en-us/iis/troubleshoot/using-failed-request-tracing/troubleshooting-failed-requests-using-tracing-in-iis

    Always quote the message especially here as you have tons of timeout related messages (for example it could be a timeout that happens for the http request between the browser and the web site or a timeout that happens when your site tries to connect to a database server etc...). iIs this message shown by the browser ?

    Also try to be as close a possible to the final configuration (ie don't use the ip if you don't want your users to use the IP). Does your site even starts in IIS ? I don't expect a timeout for this but IIS should be able to direct each incoming http request to which site. And you can't do that if you have two sites that are defined exactly the same way on a single machine (ie same ip, same port, same "host header"). A quick way to check if this is the issue might be to stop the default site and start your new site in IIS.

    If it doesn't help really try to get a detailed message for your http 500 error.

    Thursday, July 20, 2017 11:32 AM
  • User-234026806 posted

    Hi;

    I can not close to final configuration because I can not (and will not in a close future) get a domain name. Right now this application is the only site that runs at the server. Bluecoat is installed in the network. 

    Whenever I check the log, here is the error message: 

    "The World Wide Web Publishing Service (WWW Service) did not register the URL prefix http://*:80/ for site 2. The necessary network binding may already be in use. The site has been disabled. The data field contains the error number."

    Here are the visual findings: 

    (IIS Manager)

    https://drive.google.com/file/d/0ByHTCWhitIBPQldIU19WQklJU3c/view

    (When I try to reach the site in the server)

    https://drive.google.com/file/d/0ByHTCWhitIBPSGtVY0Fja3o3Zlk/view

    Thursday, July 20, 2017 12:07 PM
  • User753101303 posted

    So it seems precisely what I was talking about ie both the default site and your site are using http://*:80/ 

    Go in IIS, stop the default site and start your site and see what happens.

    Thursday, July 20, 2017 1:16 PM
  • User-234026806 posted

    Hi Patrice; 

    I have deleted the default site as can be seen in first picture. 

    Thursday, July 20, 2017 1:27 PM
  • User753101303 posted

    Have you tried to restart the www service since then ? The message was before or after that change ? For now it clearly tells that you have multiple sites using http://*:80/ 

    Also my understanding is that you browse locally. What if you browse the same way than when the default web site was showing up ?

    It seems to be a custom error page? It doesn't come from your app or maybe from a proxy server ? (it would have been interested to stop rather than to delete the web site, for now I'm not sure it ever worked when browsed locally).

    Restart the www service and browse exactly the same way than when the default site was shown. What happens?

    Thursday, July 20, 2017 2:41 PM
  • User1771544211 posted

    Hi varoulscuprens,

    (When I try to reach the site in the server)

    https://drive.google.com/file/d/0ByHTCWhitIBPSGtVY0Fja3o3Zlk/view

    In the above screenshot, I notice that the website address you request is only http://, that's not a valid address. What's the address do you use to access your website?

    The Network error could be caused by that the url you requested can't be routed to a valid website.

    Since you test this on the localhost, please try use the ip address instead of the computer name to access your website.

    http://127.0.0.1 or http://<IP Address>

    If you want to use localhost in the address, you could check if you have comment out the 127.0.0.1 localhost in the C:\Windows\System32\drivers\etc\hosts file.

    https://bowerwebsolutions.com/how-to-edit-your-local-host-file-for-testing-web-sites/

    The 500 error means that there is some error on the server side, but the 500 error shows that you can reach your IIS server. However the network error means that you can't reach your IIS server.

    Could you please share the detailed error message of the 500 error here?

    Best Regards,

    Jean

    Friday, July 21, 2017 5:55 AM
  • User-234026806 posted

    Hi Jean Sun;
    You could see only the http part because I have censored it for the security purposes. Please note that Blue Coat systems has been used in the network. How can I get the details of the 500 error from the server side? Here are the comprehensive photos of the issue:

    This is the view of the server os: 

    https://drive.google.com/open?id=0ByHTCWhitIBPc1BaLU1kRDV5dlU

    This is the view when I try to reach web site from server via dedicated ip:

    https://drive.google.com/open?id=0ByHTCWhitIBPcWdJMGpDa05wSUE

    This is the view when I try to reach the web site from server via 127.0.0.1:  (with edited hosts file)

    https://drive.google.com/open?id=0ByHTCWhitIBPS0ZPVlFQUGx0MnM

    This is the view when I try to reach the web site from client (when I shutdown the web site)

    https://drive.google.com/open?id=0ByHTCWhitIBPVGZQc3dpSW5GYUk

    This is the view when I try to reach the web site from client (when I run the web site)

    https://drive.google.com/open?id=0ByHTCWhitIBPU19nUTdyZGNIUEk

    Best regards; 

    Friday, July 21, 2017 12:25 PM
  • User1771544211 posted

    Hi varoulscuprens,

    This is the view when I try to reach the web site from server via 127.0.0.1:  (with edited hosts file)

    https://drive.google.com/open?id=0ByHTCWhitIBPS0ZPVlFQUGx0MnM

    In this condition, you are able to connect to the server, but the page you request is not found(404 error). So you can try access the specific page like http://127.0.0.1/page.html to see if it works. If it works, means that the IIS is working but you are missing some configurations.

    When you only type the http://127.0.0.1/ the IIS will check if there are any page match the default documents settings, it there is any default document, IIS will auto display the default page. Otherwise, it will return the 404 error. For more about the IIS default document settings, please check the following link.

    https://technet.microsoft.com/en-us/library/cc771439(v=ws.10).aspx

    This is the view when I try to reach the web site from client (when I run the web site)

    https://drive.google.com/open?id=0ByHTCWhitIBPU19nUTdyZGNIUEk

    The 500 error indicates the there is some error on the server side, to view the detailed error message remotely, please add the code into your web.config file.

    <configuration>
      <system.web>
        <customErrors mode="Off" />
      </system.web>
    
      <system.webServer>
        <httpErrors errorMode="Detailed" />
      </system.webServer>
    </configuration>

    Best Regards,

    Jean

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, July 24, 2017 6:37 AM
  • User-234026806 posted

    Dear Jean Sun;

    I have implemented the things you have done, but there is no solution. 

    After the implementation, I have found that two computer with different gateway can not reach themselves, so there is no way to implement it. However, thank you for your efforts.

    Sunday, July 30, 2017 12:44 PM