locked
Unspecified error in cmsscciabstractionlayer.cpp RRS feed

  • Question

  • Error: Unspecified error
    File: vsee\pkgs\vssprovider\cmsscciabstrationlayer.cpp
    Line number: 5892

     

    I get this when I try to bind the project in change source control.

     

    1. I checked out the project in with VS 2005 under XP

    2. Upgraded to VS 2008, bound the source control and checked in the project - still under XP

    3. Installed Vista Ultimate and VS 2008

    4. Did a get latest from the source control UI

    5. Opened the sln in VS 2008

    6. Went to change source control

    7. Bound the path (this went fine)

    8. Tried to bind the sln and got the above error.

     



     

     

    Thursday, April 17, 2008 5:26 PM

Answers

  • The scci code tried to diff the local project or solution file against the file in the scc database to validate the connection, and got an SCC_E_FILENOTEXIST (local file does not exist) error from VSS. It looks like the project or solution file is not where VS thinks it should be....

     

    I understand that in step 4 you used VSS Explorer to perform a GetLatest operation, then in step 5 you tried to open the solution from local disk.

     

    Mixing scc operations in VS and in the scc provider interface outside VS is not supported.

    What you should have done instead is open VS, then open the solution from source control using the File/Open dialog in VS. The solution should open and be already bound to scc - if it isn't, you also added incorrectly the solution to scc (you should use AddSolutionToScc menu items in VS, not VSSExplorer).

     

    Alin

     

     

    Friday, April 18, 2008 1:21 AM
    Moderator