locked
Developer Unlock for Windows Phone 0x64 "set the correct date and time on the phone..."

    Question

  • So yet another post asking about the infamous "Error communicating with the developer portal. Please set the correct date and time on the phone, check the Internet connection and try again later (ErrorCode:0x64)". when trying to unlock my device so I can deploy apps to it.

    I have tried everything I've seen on MSDN forums, to the extremes of re-installing Windows 8/8.1 and Visual Studio. My DNS is fine, I've reset phones, tried versions 8.0 and 8.1 of PhoneReg.exe, they're allowed on the Windows firewal, I don't have anti-virus, my device has an internet connection, the date and times are exactly the same, I've played around with location settings, date/time set automatically, pretty much every suggestion I've found.

    One thing I noticed however, is that when I log into the WP Dev Center and check my dashboard, the device is being added, so it seems there's a problem with the Dev Center coming back to my laptop/device to trigger the actual unlock on the device itself. When I try to deploy an app to the device, it does give me the deployment error "Device is developer locked" (or similar).

    Now one other thing that occurred to me was that previously my WP Dev Center did have 3 devices listed, (the max), is it sufficient to simply remove those by using the "Remove" link to be able to add new ones?

    I apologise for posting a duplicate question, but I really think there could be something else going wrong here and people should be made aware of it. How can I escalate this so someone at MS can look into my account or whatever?

    It's preventing me from properly testing my app so I can't submit it to the store.

    Any new suggestions or advice would be greatly appreciated, thanks.


    • Edited by iainco Thursday, May 29, 2014 10:08 AM
    Thursday, May 29, 2014 10:06 AM

All replies

  • What handset?   I've got no advice, but having problems too with a lumia 800 (WP7).   With the 8,1 tool, if I spam retry I can get past 0x64 to a general "Error logging into Windows Phone Dev Center..." error, that takes a while to come back.   If yours is a WP7 too,  I'm wondering if this is a WP7 phone issue -  I recently registered a colleague WP8 phone fine from the same machine.
    Thursday, May 29, 2014 10:14 AM
  • It's a Huawei Ascend W1, running Windows Phone 8.0. The PhoneReg.exe tool has worked fine before with another device of same make.

    Yep, eventually it'll say "error logging in" if you keep pressing "Retry" or leave it for a while.


    • Edited by iainco Thursday, May 29, 2014 10:29 AM
    Thursday, May 29, 2014 10:28 AM