none
System.Data.OracleClient requires Oracle client software version 8.1.7 or greater. RRS feed

  • Question

  • http://forums.asp.net/t/327841.aspx seems to suggest this relates to folder properties.

    As google has >3700 items listed when searching on this and MSDN has > 150 then it would seem this is a common problem.

    I did have my first C# .net program deployed for a 6 months .. but something changed and this error is appearing
    System.Data.OracleClient requires Oracle client software version 8.1.7 or greater.

    I have reverted back to a Delphi 7 application equivalent while I try to resolve. ...

    Maybe I should be raiseing this as an Oracle TAR on metalink .. I will do that also.

    • Moved by Harry Zhu Monday, June 22, 2009 8:25 AM (From:Visual C# General)
    Monday, June 15, 2009 3:33 AM

All replies

  • Usually, there are two components that come with any professional DBMS now-a-days. Server and Client. Server is the actual database engine and etc.

    Now, if your local machine wants to connect to an Oracle Server on some other machine, you must have Oracle Client components installed on your local machine.

    I think this error is about that.

    Thanks,
    Viral.
    Monday, June 15, 2009 6:38 AM
  • did you try connecting with the OleDbProvider for Oracle.
    Ganesh Ranganathan
    [Please mark the post as answer if it answers your question]
    Monday, June 15, 2009 6:42 AM