none
BizTalk 2010 VS developement with Oracle adapter - a tnsnames file problem RRS feed

  • Question

  • We have BizTalk 2010 running on a Windows Server 2008 R2 Standard SP 1 with System type 64-bit OS. We also have Visual Studio 2010 installed for BizTalk for our development. We installed the BizTalk adapter pack to gain access to the Oracle adapter and added the WCF-OracleDB to the list of adapters for the BizTalk Server Admin Console.

    We started our first few developments projects in Visual Studio 2010 for BizTalk after downloading from Oracle the following 32-bit development tools for VS,

    ODAC 11.2 Release 4 (11.2.0.3.0) with Oracle Developer Tools for Visual Studio

    http://www.oracle.com/technetwork/database/windows/downloads/index-101290.html

    In the VS project, we added 'Add Adapter Metadata' and selected WCF-OracleDB and proceeded to fill in the requested screen information. When the connection button is selected the following error message is displayed.

    Connecting to the LOB system has failed.

    ORA-12514: TNS:listener does not currently know of service requested in connect descriptor.

    We searched and found the tnsnames file here: D:\app\bsyren\product\11.2.0\client_1\Network\Admin\Sample  

    We then updated it with the information needed for the connect but still we receive the same error message. Something does not seem correct. Why is a tnsnames file needed if all the information needed for the connection is added to the request screens or why isn’t, at least, that information written to the tnsnames file?


    Bob Syren

    Tuesday, August 7, 2012 3:53 PM

Answers

  • I was able to solve the Oracle connection from a BizTalk project in the following way. First, I restored my development server to one before any Oracle applications were installed. Next, I only installed the Oracle 32-bit client – mainly to use tnsping. May connection attempt gave the ORA-12514 error. Following the excellently written instructions by Ed Stevens at,

    http://edstevensdba.wordpress.com/2011/03/19/ora-12514/

    I tracked down the ServiceName in the listener.ora file on the Oracle server I was attempting to connect to. This information along with making sure the  username is in upper case – seems lower case or mixed case does not work - enabled a connection to Oracle.


    Bob Syren


    • Marked as answer by bsyren Friday, August 17, 2012 2:56 PM
    • Edited by bsyren Friday, August 17, 2012 2:57 PM grammer
    Friday, August 17, 2012 2:55 PM

All replies

  • Hi. 

    The file tsnames.ora must be in this place D:\app\bsyren\product\11.2.0\client_1\Network\Admin instead D:\app\bsyren\product\11.2.0\client_1\Network\Admin\Sample 



    Espero ter ajudado
    Ruth Resende
    MVP, MCTS - Biztalk Server
    www.biztalkbrasil.com.br
    Twitter: @ruthresende

    Tuesday, August 7, 2012 8:23 PM
  • Check this link

    Shashi

    Tuesday, August 7, 2012 11:18 PM
  • A great way to check if the connection could be established is to use the TNSPing. As Ruth states you should verify that the tnsnames.ora file is located in the admin folder and not sample. Also, make sure you only have one installation of Oracle and that BizTalk is using the correct one.

    But your ORA error states that you have something wrong in either the TNSNames file or in your path in BizTalk.

    Best regards

    Tord Glad Nordahl
    Bouvet ASA, Norway
    http://www.BizTalkAdmin.com |@tordeman

    Please indicate ”Mark as Answer” if this post has answered the question.

    Wednesday, August 8, 2012 5:12 AM
  • Already thought it may need to be in the Admin folder but this did not help,.

    Bob Syren


    • Edited by bsyren Wednesday, August 8, 2012 11:34 AM
    Wednesday, August 8, 2012 11:22 AM
  • I tried PNSPing and received,

    C:\Users\bsyren>TNSPing
    'TNSPing' is not recognized as an internal or external command,
    operable program or batch file.

    I then searched all drives for TNSPing but did not find it.


    Bob Syren

    Wednesday, August 8, 2012 1:28 PM
  • Hi Bob,

    You should be able to connect without the tnsnames files entry. You will need to check the properties that you are setting in the configure URI section before you hit connect. Also for TNSPing to work you would need to set the path using command prompt  eg SET path=c:\oracle\product\10.1.0\db_1\bin, check the path on your local before you run this command. After setting the path you can run TNSping with the name of entry in the TNSNames. Hope this helps.


    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.

    Wednesday, August 8, 2012 2:08 PM
  • Yes Bali. My understanding is the same. Correctly configuring, on the configuration adapter screen, the correct "Connection Descriptor" values on the "URI Properties" tab should allow me to connect to the Oracle server and not use the tnsnames.ora file. But, I still receive the following message:

    Connecting to the LOB system has failed.

    ORA-12514: TNS:listener does not currently know of service requested in connect descriptor.

    Can the "Binding Properties" tab settings help to clear this failure?


    Bob Syren

    Wednesday, August 8, 2012 4:24 PM
  • I was able to solve the Oracle connection from a BizTalk project in the following way. First, I restored my development server to one before any Oracle applications were installed. Next, I only installed the Oracle 32-bit client – mainly to use tnsping. May connection attempt gave the ORA-12514 error. Following the excellently written instructions by Ed Stevens at,

    http://edstevensdba.wordpress.com/2011/03/19/ora-12514/

    I tracked down the ServiceName in the listener.ora file on the Oracle server I was attempting to connect to. This information along with making sure the  username is in upper case – seems lower case or mixed case does not work - enabled a connection to Oracle.


    Bob Syren


    • Marked as answer by bsyren Friday, August 17, 2012 2:56 PM
    • Edited by bsyren Friday, August 17, 2012 2:57 PM grammer
    Friday, August 17, 2012 2:55 PM