Why my setup project asks for .net 3.5 when .net 4 installed? RRS feed

  • Question

  • I created VS setup project and started it on XP SP2 with .Net framework 4 installed (only!), but my installer says:

    "This setup requires .Net Framework version 3.5 ...."

    Is this correct? Backward compatibility isn't available, or I did something wrong?

    Wednesday, June 9, 2010 7:23 PM


  • Please let me better explain what is going wrong here.

    .NET Framework 3.5 is an add-on for the .NET Framework 3.0 and.NET framework 3.0 is an add-on for the .NET Framework 2.0. It means that the runtime of .NET Framework 2.0 is the base for the next versions.

    The .NET Framework 4.0 has a new runtime that is not based on .NET Framework 2.0.
    By default, an application targeting for.NET Framework 3.5 cannot run on the .NET framework 4.0.

    You can change this default behavior, since .NET framework 4.0 is backward compatible.

    In order to do that you should create a file with the following name: “yourApplication.EXE.CONFIG” and put it on the same directory of your exe.

    Inside this file please write:

       <supportedRuntime version="v4.0"/>


    For further information, please see:



    Carmelo Pulvirenti

    • Marked as answer by YiChun Chen Friday, June 11, 2010 8:39 AM
    Thursday, June 10, 2010 9:25 AM