none
Issue with HP Thin Client after capture OS Image Windows Embedded Standard 2009 RRS feed

  • Question

  • Hi guys,

    I have the following issue. I have an HP Thin Client, and I need to create an OS Image with Windows Embedded Standard 2009 for this device. I download and I applied the base image from the HP web site.  After capturing the image, my issue is the HP security lockpad for enable and disable the Enhanced Write Filter not working properly. I disabled the EWF before capturing the image, and after applying the captured image, when I try to enable the EWF, I received the following error: "EwfMgrEnable failed with error 0x00000057". I try to enable the EWF from the Control Panel, and after enable it, and reboot the machine, the security padlock keeps in red state, and appears like the disable state, receiving the same error when I try to enable it. 

    For capturing the image, I do the following steps:

    • I disable the Enhanced Write Filter.
    • I reboot the machine.
    • I execute the FBRESEAL located in the directory c:\Program Files\Hewlett-Packard\ThinState Capture\Tools. (The only location of this file in the Thin Client).
    • After executing the FBRESEAL, the machine restarts automatically, without showing any messages.
    • During the reboot, I configure the Thin Client for booting in Windows PE (by USB flash media).
    • In Windows PE environment, I execute the following command: imagex.exe /capture /compress maximum c:\ d:\IMG.wim "HP Image" 
    • The process completes succesfully.
    • I apply this captured image to the same and other Thin Client with the same model, booting in Windows PE, with the following command: imagex.exe /apply d:\IMG.wim 1 c:
    • The process completes succesfully
    • I reboot the Thin Clients
    • I login in the Thin Clients

     

    If you have and similar experiences, please, help me to solve this.

     

    Thanks.

     

    Rodrigo

    Tuesday, January 17, 2012 1:39 PM

All replies

  • The issue might be how EWF is configured. If RAM overlay, then there is a small secondary partition that you are not capturing with imagex. The clone is failing to boot as it cannot find the secondart - EWF overly - patition.

    If you go to the command prompt and run EWFMGR, can you see if the overlay type is RAM or RAM-REG?

    -Sean 


    www.sjjmicro.com / www.seanliming.com / www.annabooks.com, Book Author - Pro Guide to WES 7, XP Embedded Advanced, Pro Guide to POS for .NET
    Tuesday, January 24, 2012 4:21 PM
    Moderator
  • I also had this problem, but I couldnt find clear information on how to solve it.
    Nor a link too the moved page.
    I did manage to get rid of the error.

    When logged in as Administrator: Control Panel > HP Write Filter Configuration >  EWF Main > Commit data to volume. Now the Boot command will change from No Command > Commit.

    After I did these steps and 2 reboots, EWF worked the padlock was green again. and no more EWFMgrEnable 0x00000057 error.

    I hope this helped!

    • Edited by Mitch Bove Friday, November 6, 2015 9:17 AM added information
    Friday, November 6, 2015 9:12 AM