none
Kinect v2 pauses frequently RRS feed

  • Question

  • My kinect v2 often stops working . That means while aquiring frames it suddenly stops (lights go off) and after a few seconds lights go on again and it continues delivering frames.

    Has anybody expirienced the same problem?

    Thursday, October 2, 2014 5:51 PM

All replies

  • When does it do this? When running your custom code? If so make sure you release all the frames as soon as you can. If it's the sample SDK applications, make sure you have the latest build: 1409...

    Sr. Enterprise Architect | Trainer | Consultant | MCT | MCSD | MCPD | SharePoint TS | MS Virtual TS |Windows 8 App Store Developer | Linux Gentoo Geek | Raspberry Pi Owner | Micro .Net Developer | Kinect For Windows Device Developer |blog: http://dgoins.wordpress.com

    Thursday, October 2, 2014 5:59 PM
  • Makes no differnce wheter I run my own code or when I connect with Kinect Studio v2 to the camera. And yes, I have the September SDK Build installed.
    Thursday, October 2, 2014 6:02 PM
  • I was having similar issues after installing build 1409 - sensor seems to restart every 10 seconds, even when an app is connected to the sensor without processing frames.

    There's another thread here about similar problems where the Kinect service is crashing out and restarting, check task manager to see if this is your issue.

    I found that just disconnecting the sensor from USB until I'm logged in works around it for now.

    I think there's something environmental at the root of it as a clean install of Windows 8 doesn't get the same problem on the same rig. And its working fine for most people...

    Thursday, October 2, 2014 10:24 PM
  • KInect Service doues not crash, only its  CPU Usage drops to 0% when Kinect goes off. With Kinect running it uses about 8% CPU.
    Friday, October 3, 2014 10:49 AM
  • Does it crash at a similar frequency (every 10 secs)?

    Have you tried depowering the Kinect, unplugging it from USB, restarting the PC, logging in, re-kinnecting and then trying your app ? Sounds crazy I know.. but it works for me.

    Friday, October 3, 2014 11:26 AM
  • Yes it restarts about every 10 seconds. But your suggestions did not work. Same behavior again.
    Monday, October 6, 2014 7:59 AM
  • this is a tracking issue that has come up in a previous thread. Are you seeing KinectService shutdown in TaskManager?


    Carmine Sirignano - MSFT

    Monday, October 6, 2014 7:18 PM
  • No, Kinect Service does not shut down. It just seems to go idle as it uses no CPU while the camera is offline/rebooting or whatever.
    Monday, October 6, 2014 7:21 PM
  • Quick update on my own topic: Kinect reboots only occur when we are working with a remote desktop session on the pc where the kinect is connected.

    with keyboard mouse and monitor everything works fine. this is reproducable on different machines.

    an explanation for this?

    Wednesday, October 22, 2014 7:23 PM
  • Be sure to change the audio setting in RDP client to "play on remote server" and see if that changes the behavior.

    Carmine Sirignano - MSFT

    Wednesday, October 22, 2014 8:36 PM
  • Wow, changing the audiosettings worked. Thanks a lot!
    Friday, October 24, 2014 7:31 AM