none
Application Error after Installing .Net Framework 3.5 RRS feed

  • Question

  • Hi Support,

    Applicaiton running without error on .Net framework 2.0  and after installing the .Net framework 3.5

    The application runned on .Net framework 2.0 hanging. This occurs even after uninstalling the .Net framework 3.5

    May i know what as occured.

    Regards

     

    Thursday, July 12, 2012 3:59 AM

All replies

  • What is your Windows version and service pack level?

    Have you installed .NET Framework 3.5 SP1?

    Please run tis tool to verify your .NET Framework installation:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with .NET 3.5 selected, then post the first 15 lines and last 15 lines of tool output here.

    Thursday, July 12, 2012 12:30 PM
  • Hi VinodhSankar,

    Thanks for your post.

    To know the reason of your issue, I recommend you use MVP's tool to verify .NET first.

    If .NET 3.5 didn't install well, we have to repair it. To do this, please tell me your OS version and service pack level . 

    However, we may also need to check your application. What's the application name? 

    Did you build it yourself? If so, what's your language type and project type?

    Regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Friday, July 13, 2012 6:47 AM
    Moderator
  • Hi Barry Wang,

    Thank you very much for the reply,

    OS Version : 2003 and Service Pack Level : SP2

    Application is build by myself and language used is ASP.NET 2.0 / VB.NET and project type : web

    It was running perfectly for almost 4 years, this occured after installing the .Net framework 3.5 last week and even after uninstalling the .Net framework 3.5 still the problem occurs.

    Regards

    Vinodh 

    Monday, July 16, 2012 2:09 AM
  • Hi,

    Yes installed .Net framework 3.5 SP1. once after getting the system Hang have uninstalled the .Net Framework 3.5, System hang even after uninstall.

     

    Monday, July 16, 2012 2:22 AM
  • One mare time...

    Please run tis tool to verify your .NET Framework installation:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with .NET 3.5 selected, then post the first 15 lines and last 15 lines of tool output here.

    Monday, July 16, 2012 2:22 AM
  • Hi VinodhSankar,

    How is your issue now?

    Could you please verify .NET first?

    I'm doing a follow up here.

    Regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Tuesday, July 17, 2012 5:11 AM
    Moderator
  • Hi Pvdg,

    First 15 lines

    ======================================================================
    [07/17/12,16:22:34] Beginning of new SetupVerifier activity logging session
    [07/17/12,16:22:34] Activity log file location: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\1\setupverifier_main_07-17-12_16.22.34.txt
    [07/17/12,16:22:34] Error log file location: C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\1\setupverifier_errors_07-17-12_16.22.34.txt
    [07/17/12,16:22:34] Build created on June 29, 2012
    [07/17/12,16:22:34] Detected operating system: Windows Server 2003 (x86)
    [07/17/12,16:22:34] Install state for .NET Framework 1.0: not installed.
    [07/17/12,16:22:34] Install state for .NET Framework 1.1: installed with service pack 1.
    [07/17/12,16:22:34] Install state for .NET Framework 2.0: installed with service pack 2.
    [07/17/12,16:22:34] Install state for .NET Framework 3.0: installed with service pack 2.
    [07/17/12,16:22:34] Install state for .NET Framework 3.5: installed with no service packs.
    [07/17/12,16:22:34] Install state for .NET Framework 4 Client: not installed.
    [07/17/12,16:22:34] Install state for .NET Framework 4 Full: not installed.
    [07/17/12,16:22:34] Install state for .NET Framework 4.5: not installed.
    [07/17/12,16:22:34] Not adding product '.NET Framework 1.0' because it is not currently installed
    [07/17/12,16:22:34] Not adding product '.NET Framework 1.1' because it is not currently installed
    [07/17/12,16:22:34] Not adding product '.NET Framework 2.0' because it is not currently installed
    [07/17/12,16:22:34] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed
    [07/17/12,16:22:34] Not adding product '.NET Framework 3.0' because it is not currently installed
    [07/17/12,16:22:34] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed
    [07/17/12,16:22:34] Not adding product '.NET Framework 3.5 SP1' because it is not currently installed
    [07/17/12,16:22:34] Not adding product '.NET Framework 4 Client' because it is not currently installed
    [07/17/12,16:22:34] Not adding product '.NET Framework 4 Full' because it is not currently installed
    [07/17/12,16:22:34] Not adding product '.NET Framework 4.5' because it is not currently installed
    [07/17/12,16:22:39] Starting verification for product .NET Framework 2.0 SP2
    [07/17/12,16:22:39] Section [Files - .NET Framework 2.0 (Common)] - start parsing entries

    Last 15 Lines

    [07/17/12,16:22:48] Section [Registry - .NET Framework 2.0 (Common)] - stop parsing entries
    [07/17/12,16:22:48] Section [Registry - .NET Framework 2.0 (32-bit)] - start parsing entries
    [07/17/12,16:22:48] Key: HKLM\SOFTWARE\Microsoft\.NETFramework
     Value: InstallRoot
     Expected Data: c:\windows\microsoft.net\framework\
     Actual Data: c:\windows\microsoft.net\framework\
    [07/17/12,16:22:48] Section [Registry - .NET Framework 2.0 (32-bit)] - stop parsing entries
    [07/17/12,16:22:48] Not running action 'Registry - .NET Framework 2.0 (64-bit)' for product '.NET Framework 2.0 SP2' because the OS condition does not match
    [07/17/12,16:22:48] Not running action 'Registry - .NET Framework 2.0 (Wow6432Node)' for product '.NET Framework 2.0 SP2' because the OS condition does not match
    [07/17/12,16:22:49] Section [Registry GE - .NET Framework 2.0 SP2 (Common)] - start parsing entries
    [07/17/12,16:22:49] Key: HKLM\SOFTWARE\Microsoft\NET Framework Setup\NDP\v2.0.50727
     Value: SP
     Expected Data: 2
     Actual Data: 2
    [07/17/12,16:22:49] Section [Registry GE - .NET Framework 2.0 SP2 (Common)] - stop parsing entries
    [07/17/12,16:22:49] Section [Registry GE - .NET Framework 2.0 SP2 (32-bit)] - start parsing entries
    [07/17/12,16:22:49] Section [Registry GE - .NET Framework 2.0 SP2 (32-bit)] - stop parsing entries
    [07/17/12,16:22:49] Not running action 'Registry GE - .NET Framework 2.0 SP2 (64-bit)' for product '.NET Framework 2.0 SP2' because the OS condition does not match
    [07/17/12,16:22:49] Processing custom action 'Custom Action - .NET Framework 2.0 test application'
    [07/17/12,16:22:49] ExecutablePath = 'Netfx20TestApplication.exe'
    [07/17/12,16:22:49] FriendlyName = '.NET Framework 2.0 test application'
    [07/17/12,16:22:49] TimeoutSeconds = '300'
    [07/17/12,16:22:49] WaitOnExit = 'true'
    [07/17/12,16:22:49] Silent = 'true'
    [07/17/12,16:22:49] Launching process 'Netfx20TestApplication.exe' now
    [07/17/12,16:22:49] Process successfully launched. Waiting 300 seconds for it to complete.
    [07/17/12,16:22:49] Process 'Netfx20TestApplication.exe' exited with return code 0
    [07/17/12,16:22:49] Section [Files - .NET Framework netfxperf.dll] - start parsing entries
    [07/17/12,16:22:49] File C:\WINDOWS\system32\netfxperf.dll (version 1.1.4322.573) is installed on the system
    [07/17/12,16:22:49] Section [Files - .NET Framework netfxperf.dll] - stop parsing entries
    [07/17/12,16:22:49] Verification succeeded for product .NET Framework 2.0 SP2

    Tuesday, July 17, 2012 9:54 AM
  • Hi,

    Issue is still the same even after uninstall the .Net Framework 3.5
    Now, only .Net Framework 2.0 SP2 is installed and with all security updates ( still the application hangs)

    Regards

    Thursday, July 19, 2012 11:14 AM
  • Hi VinodhSankar,

    Sorry for the late track.

    But from the verification, .NET 2.0 installed successfully.

    The hang issue was not because .NET 2.0 but due to your application.

    Since your application is ASP.NET project from "

    Application is build by myself and language used is ASP.NET 2.0 / VB.NET and project type : web

    "

    Please open a new thread here http://forums.asp.net/ 

    Regards,


    Barry Wang [MSFT]
    MSDN Community Support | Feedback to us

    Monday, August 6, 2012 6:22 AM
    Moderator