none
Web App network connectivity issue RRS feed

  • Question

  • Hi,

    My Web app is unable to connect to other machines. 

    When I try a  simple ping from Debug Console, I get 

    Unable to contact IP driver. General failure.

    Is there a way to quick fix this?

    Thanks

    Siva

    Monday, November 14, 2016 1:24 PM

All replies

  • Hi,

    I would suggest you to check this article if you have missed something?
    https://azure.microsoft.com/en-us/documentation/articles/web-sites-integrate-with-vnet/

    Regards,
    Azam Khan

    Monday, November 14, 2016 5:42 PM
  • Hi Siva,

    According to your description, I tried to ping "www.google.com" and I could reproduce your issue. After searching the web, I found this feedback.

    For security consideration, App Service instances block ICMP (Internet Control Message Protocol), so you can’t use the traditional ping command.

    Then, I tried to use TcpPing.exe from Kudu to test network connectivity. Here is my test, you could refer to it.

    Also, please try to follow the article provided by Azam Khan and find out whether you could resolve this issue.

    Best Regards,

    Bruce

    Wednesday, November 16, 2016 7:50 AM