SQL 2012 installation for Failover Cluster failed


  • While installation of SQL 2012 on FOC validation fails on "Database Engine configuration" page with following error:

    The volume that contains SQL Server data directory g:\MSSQL11.MSSQLSERVER\MSSQL\DATA does not belong to the cluster group.

    Want to know how does SQL installation wizard queries volumes configured with Failover Cluster. does it:

    - Enumerate "Physical Disk" resources in FOC

    - does it enumerate all Storage Class resources in FOC for getting the volume list

    - or it depends on WMI (Win32_Volume) to get volumes ?

    The wizard correctly discovers volume g:\ in its FOC group on "Cluster Resource Group" and "Cluster Disk Selection" page. but gives the error on Database configuration page.

    Any help in this would be appreciated.

    Thanks in advance


    Rakesh Agrawal

    Wednesday, November 28, 2012 5:34 AM

All replies

  • Hi there,

    Are you trying to install sql cluster and add nodes to it. in that case you need shared disks. make sure they are properly allocated and your iscsci targets are ok and connected.

    If you do not use any shared disks you won't get this error.

    let me know if you need more info, i have recently did lots of work in this area.



    Wednesday, November 28, 2012 6:02 AM
  • Hi Kumar,

    I have 2 nod FOC cluster created with shared storage configured in a Group. When i run the sql installation wizard it is able to dectect the group and storage which i have in FOC. but the validation fails on Database configuration page.

    The difference here is i am using custom storage class resource not the PhsyicalDisk resource in FOC. hence wanted to understand how SQL wizard is getting/queriying  the list of volumes configured in FOC.


    Rakesh Agrawal

    Wednesday, November 28, 2012 9:04 AM
  • Hii,

    G:\ which you are using is your local drive or drive of shared disk .....

    Regards, Ashish ----------------------------------------------------------- Please mark answered if I've answered your question and vote for it as helpful to help other user's find a solution quicker..

    Wednesday, November 28, 2012 12:36 PM
  • it is a shared drive and correctly detected by SQL installation wizard for its "Cluster Disk selection" page. Also the FOC group was correctly discovered in "Cluster Resource Group".

    Following is the screen shot from "Cluster disk selection" and "database engine configuration" wizards.

    in below screen shots testsql is the resource which manages g:\, if we notice the "Cluster Disk selection" dialog, we are able to see that testsql is correctly configured and online in FOC.

    Rakesh Agrawal

    Wednesday, November 28, 2012 2:18 PM
  • wheck on the active node disks are online and available.(from computer manage)

    if all good disconnect the targets and reconnect. format the disks again, it must be your first connection so should be ok.

    give a try and let me know. i have had all these problems when i first started, it takes some time to get it work in the first time. onceyou know how to set up it will be easy.

    Wednesday, November 28, 2012 8:30 PM
  • Thank Kumar for quick response. I have tried with disconnect/reconnect but no success. What i think is playing a part here how this Dabase configration validates that a volume is configured with FOC. In my case this volume is managed by a "Volume Manager Disk Group" resource. which is another storage class resource like "Physical Disk".

    The questions still remains how does the wizard gets volume list configured in FOC for validation. does it:

    - Enumerate "Physical Disk" resources in FOC

    - does it enumerate all Storage Class resources in FOC for getting the volume list

    - or it depends on some WMI class to get volumes and if yes, what is that.


    Rakesh Agrawal

    Thursday, November 29, 2012 2:54 AM
  • you must have enabled MPIO before validating your cluster. cluster will have all the storage disks information.

    if you look at the cluster validation test results you get an idea what it is checking and other information.

    some of the tests are checking networks, checking targets, checking storage diska etc. it pings other nodes and make sure they are reachable........

    please go through the results after cluster validation.



    • Edited by Kumar muppa Thursday, November 29, 2012 8:37 AM
    Thursday, November 29, 2012 8:37 AM
  • Can you please check if there is any disk in the cluster which is not in online state? Please run below script following the steps.
    1. Save a script as "Disk.vbs" and use use CSCRIPT to run it.
    2. Syntax: CSCRIPT <Disk.vbs> <Windows Cluster Name>

    < Script>
    Option Explicit
    Public objArgs, objCluster

    Public Function Connect()
    ' Opens a global cluster object. Using Windows Script Host syntax,
    ' the cluster name or "" must be passed as the first argument.

    Set objArgs = WScript.Arguments
    if objArgs.Count=0  then
     wscript.Echo "Usage Cscript  <script file name>  <Windows Cluster Name> "
    end IF

    Set objCluster = CreateObject("MSCluster.Cluster")
    objCluster.Open objArgs(0)

    End Function

    Public Function Disconnect()

    ' Dereferences global objects.  Used with Connect.

     Set objCluster = Nothing
     Set objArgs = Nothing
    End Function


    Dim objEnum

    For Each objEnum in objCluster.Resources
     If objEnum.ClassInfo = 1 Then
      WScript.Echo ObjEnum.Name
      Dim objDisk
      Dim objPartition
      On Error Resume Next
       Set objDisk = objEnum.Disk
       If Err.Number <> 0 Then
        WScript.Echo "Unable to retrieve the disk: " & Err
        For Each objPartition in objDisk.Partitions
         WScript.Echo objPartition.DeviceName
       End If
     End If



    Thursday, November 29, 2012 2:08 PM
  • Thanks for the script. I am able to get the G: and testsql resource using this script. All the custom storage class resources of my "Volume Manager Disk Group" type are correctly returned along with "Physical Disk" resource.

    Any other idea on what to look for ? would it be possible that DatabaseConfiguration page of the SQL installation wizard is enumerating only "Physical Disk" resources instead of all "Storage Class" resources in the cluster ?

    Rakesh Agrawal

    Thursday, November 29, 2012 3:19 PM
  • Rakesh,

    Did your issue got resolved? I am stuck with the same issue. I have a cluster (3 nodes) which is already running an instance of SQL Server 2008 and I am trying to install SQL Server 2012 on a difference resource group. The storage is from EMC VMX configured using Veritas volume manager. The validation on 'Database engine configuration' goes through fine in 2008 but fails 2012.



    Wednesday, August 14, 2013 7:37 PM
  • When you (re)run cluster validation, does the disk appear as a validated disk? Also, if you are presenting disks from a EMC VNX array to W2K8, why are you using Veritas volume manager?
    Friday, August 16, 2013 2:03 AM
  • Hi Kishore,

    My issue was very specific to SQL2012 clustered installation on Windows 2012. For us the problem got resolved in SQL2012 SP1 installer.

    Can you please let me know which version of SFW you are using on which OS. If you still have issues i would say talk to Symantec support once and they should be able to help you with this.



    Rakesh Agrawal

    Friday, August 16, 2013 4:05 AM
  • My guess is that it has something to do with storage configuration. Are you using Windows Server 2012 in your failover cluster? Since Windows Server 2012 Failover Cluster implements storage spaces, there are firmware updates that you need to use with your storage to work with Windows Server 2012. So, even if the disks worked with Windows Server 2008/SQL Server 2008 failover cluster, you will have storage warnings with Windows Server 2012 and errors when installing SQL Server 2012

    Edwin Sarmiento SQL Server MVP
    Blog | Twitter | LinkedIn

    Tuesday, August 20, 2013 6:11 AM
  • Data root directory do not used "volume drive G:\" but enter the "cluster group name and share files". For my example, "\\HASQL01\SQLDATA"

    and make sure that your "sql service accounts "agent and server" previously sql installation screen that have an administrator privilege.

    take me hours to make it run :-)

    Monday, January 12, 2015 1:29 PM
  • Go Backup to installation and select all avaliable cluster disk
    Sunday, June 04, 2017 12:32 PM