none
Win 7 RTM X64 - Net 3.5 SP1 fails RRS feed

  • Question

  • I've had some weird issues with Visual Studio 2008 - Got a tips from another forum to check the health of my .NET install. So I downloaded Aarons .NET Verifier tool. Net 2(sp2) and .Net 3 verifies: OK, but 3.5 SP1 fails.

    I removed 3.5 sp1 via "turn on/off windows features". Reboot - "turn on" - and it started installing, hung about 98% done(I left it going over the night). Reboot - Net verify still fails on 3.5 sp1

    So what to do? I can't install any "other" 3.5sp1 package?

    Please advice!

    TIA!

    Regards,

      Lars Siden

    -------------- Log ---------------------- Here is where it fails:

    [11/06/09,20:11:48] Section [Registry GE - .NET Framework 3.5 SP1 (Wow6432Node)] - stop parsing entries
    [11/06/09,20:11:48] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - start parsing entries
    [11/06/09,20:11:48] File C:\Program Files (x86)\Reference Assemblies\Microsoft\Framework\v3.0\RedistList\FrameworkList.xml is installed on the system
    [11/06/09,20:11:48] Section [Files - .NET Framework 3.0 SP1AndLater (Common)] - stop parsing entries
    [11/06/09,20:11:48] Processing custom action 'Custom Action - .NET Framework 2.0 test application'
    [11/06/09,20:11:48] ExecutablePath = 'Netfx20TestApplication.exe'
    [11/06/09,20:11:48] FriendlyName = '.NET Framework 2.0 test application'
    [11/06/09,20:11:48] TimeoutSeconds = '300'
    [11/06/09,20:11:48] WaitOnExit = 'true'
    [11/06/09,20:11:48] Silent = 'true'
    [11/06/09,20:11:48] Launching process 'Netfx20TestApplication.exe' now
    [11/06/09,20:11:48] Process successfully launched. Waiting 300 seconds for it to complete.
    Friday, November 6, 2009 7:10 PM

Answers

All replies

  • Hi Lars

    Can you see the option "Microsoft .NET Framework 3.5.1" in "Turn Windows features on or off" under control panel?

    The .NET Framework 2.0 SP2, 3.0 SP2 and 3.5 SP1 are all installed as OS components on Windows 7, we cannot uninstall them from Win7 but to disable them.

    As for verify tool, please use the one that with Win7 support: http://blogs.msdn.com/astebner/archive/2009/07/27/9850215.aspx

    Thanks!

    Figo Fei

    MSDN Subscriber Support in Forum

    If you have any feedback on our support, please contact msdnmg@microsoft.com


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Monday, November 9, 2009 10:43 AM

  • Hello,

    I have used the windows feature to turn 3.5.1 on and off to "re-install" it with win 7. If I check both non-http-activation and http-activation under 3.5.1 the installer never finish(may be related to some IIS 7 setting?)

    I'll test the new win 7 verify tool.

    regards,  Lars Siden

    Monday, November 9, 2009 1:21 PM

  • I have now tried the new verification util(it was the one I already got).

    I found the "error log file"
    ======================================================================
    [11/09/09,21:02:10] Beginning of new SetupVerifier error logging session
    [11/09/09,21:02:10] Activity log file location: C:\Users\LSiden\AppData\Local\Temp\setupverifier_main_11-09-09_21.02.10.txt
    [11/09/09,21:02:10] Error log file location: C:\Users\LSiden\AppData\Local\Temp\setupverifier_errors_11-09-09_21.02.10.txt
    [11/09/09,21:02:10] Build created on October 19, 2009
    [11/09/09,21:02:10] Detected operating system: Windows 7 (x64)
    [11/09/09,21:02:17] File C:\Windows\Microsoft.NET\Framework\v3.5\Windows Presentation Foundation\NPWPF.dll is not installed on the system
    [11/09/09,21:02:19] Verification failed for product .NET Framework 3.5 SP1

    So why don't I have NPWPF.dll?

    Cheers, Lazze
    Monday, November 9, 2009 8:03 PM

  • I sort of solved it. I copied

     C:\Windows\Microsoft.NET\Framework\v3.5\Windows Presentation Foundation

    From my Win 2008 x64 dev server to my Win 7 x64 installation. Now the verify util says "OK"

    Maybe this has some other ill effects?

    Cheers, Lazze

    Monday, November 9, 2009 8:33 PM
  • Hi Lazze

    As .NET Framework 3.5 SP1 is a Windows Component of Win7, in case of any problem of .NET Framework installation, you may need to repair the Win7 to fix it (use the cmd prompt: sfc /scannow )
    Here is an article for details of how to fix .NET 2.0/3.0 in Vista, the steps can still be applied to .NET 3.5.1 in Win7: http://blogs.msdn.com/astebner/archive/2007/03/26/how-to-repair-the-net-framework-2-0-and-3-0-on-windows-vista.aspx .

    If you have any specific problem, please feel free to let me know.

    Thanks.

    Figo Fei

    MSDN Subscriber Support in Forum

    If you have any feedback on our support, please contact msdnmg@microsoft.com



    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Tuesday, November 10, 2009 2:38 AM