none
SharePoint 2016 workflow internal status remains 'Started' even after it completes RRS feed

  • Question

  • Hello,

    I have a weird situation. SharePoint 2016 farm, WFE/CACHE+APP/SEARCH+SQL, all latest updates for SP 2016, Service Bus, and Workflow Manager. WFM & SB are installed on APP server. WFE has WFM client installed. All connected, all working.

    I created a simple SPD 2013 workflow on a list, which is triggered on item create and change. No versioning, no checking/checkout on the list, all other known possible causes of misbehavior eliminated.

    When WF starts, no matter how it is triggered, it completes successfully. Tried many times, never hangs. The WF has 3 internal stages - initialization, send an email, and completion. Each stage is 1-2 simple steps, no custom actions. Again, everything works fine when I do one test at a time.

    The weirdness happens if I try updating a list item more than once within one minute. For example, if I update the item twice within one minute, the items indeed gets updated twice (data saved), workflow also starts two times, and I receive two emails, so everything seems to be fine. However, if I go to the Workflows page for that item, I can see that one the two workflow instances is completed, and the other is shown as 'Started' and in the 'Initialization' phase. It remains 'Started' forever. I tried terminating the workflow using UI and PowerShell - nothing changes, it remains 'Started' - although it already completed. If I check WF Instance Management DB, Instances table, the value in the WorkflowStatus column is also 'Started'.

    I wonder if anyone experienced anything like this, which appears to be a bug in the product. I tried reporting this to Microsoft, but could not find a no-cost way to report a bug in their product without opening a support ticket and paying for it.

    Thank you

    Wednesday, June 28, 2017 8:50 PM

All replies

  • After spending hours and hours of fruitless testing, I finally got it fixed on July 13, when Microsoft released CU4 for Workflow Manager 1.0. Now everything works like a charm!

    Thursday, July 13, 2017 1:11 PM
  • Hi...it seems very strange but the behavior that you notice before CU4 form me is started after installing CU4...awesome...
    Friday, September 29, 2017 8:38 AM