none
.NET 3.5 uninstall problems RRS feed

  • Question

  • Hi *,

     

    after installing new .NET 3.5 framework, we encoutered some changes in WPF, which produced major issues in an application.

     

    As a temporary solution, I wanted go back to previous versions of assemblies on target machine. So I uninstalled .NET framework 3.5, disabled .NET framework 3.0 and reenabled .NET framework 3.0 on Vindows Vista.

     

    Unfortunatelly, new builds of .net assemblies still resides in winsxs directory, so every time I enable .NET 3.0, windows copies those into Reference Assemblies\...\v.3.0\ directory.

     

    Somebody have an Idea how to revert back to previous version?

     

    Thanks, have a nice day

     

    Peter

    Tuesday, November 20, 2007 2:42 PM

Answers

  •  

    If you want to completely remove .NET Framework 3.5 from off your Vista RTM OS, you need to do the following:

    1. Uninstall .NET Framework 3.5

    2. Uninstall the following KBs by using Installed Updates.

    - KB929300 (.NET Framework 3.0 Cumulative Update 1)

    - KB110806 (.NET Framework 2.0 Cumulative Update 1)

     

    After doing this successfully, you will have removed the 3.0 Updates required by 3.5.

     

    Aaron

    Tuesday, November 20, 2007 8:12 PM
    Moderator

All replies

  •  

    If you want to completely remove .NET Framework 3.5 from off your Vista RTM OS, you need to do the following:

    1. Uninstall .NET Framework 3.5

    2. Uninstall the following KBs by using Installed Updates.

    - KB929300 (.NET Framework 3.0 Cumulative Update 1)

    - KB110806 (.NET Framework 2.0 Cumulative Update 1)

     

    After doing this successfully, you will have removed the 3.0 Updates required by 3.5.

     

    Aaron

    Tuesday, November 20, 2007 8:12 PM
    Moderator
  • Aaron, I know I'm coming in incredibly late on this thread, but was hoping you might still be monitoring it. 
    I installed .NET Framework 3.5 the day before yesterday and when I boot up XP an error as follows appears. "Component 'MSWINSCK.OCX' or one of its dependencies not correctly registered: a file is missing or invalid."
    There is very little info during search, but it seems the problem is related to either 3.5 or an Active X problem. I have installed the SP1 and reinstalled Active X to no avail and in Add and Remove Programs .NET Framework 3.5 is not listed as uninstallable. After searching everywhere, you seem to have a serious grasp of 3.5. Can you help me figure this problem out. By the way, it is not affecting the operation of anything that I can see, just 2 warnings when I boot that is annoying. Also, I thought of using System Restore but I installed Avast! after 3.5 and it did a 2 hour search before boot and don't want to take a chance on the effects of Restore on it.
    Thank you,
    Rick
    Friday, August 29, 2008 2:59 PM
  •  Just in case anyone else has this problem, here is the solution. Go to http://www.skyenet.net/~cbeelby/pente/ and click on the MSWINSCK.OCX link and save file to desktop. Open your system32 folder and copy and paste which will put this missing OCX file in its proper place and problem solved. For some reason Microsoft left this file out of its download and it is obviously needed for .NET Framework 3.5 and Active X to work properly.
    Very unusual to see something like this missing from Microsoft!
    Thanks again,
    Rick
    Friday, August 29, 2008 3:30 PM