locked
Reporting Services error (The permissions granted to user ... are insufficient for performing this operation.) RRS feed

  • Question

  • Hi,

     

    I have a problem with accessing reports in Reporting Services from my Team Foundation Server installation. My user account is a member of the global domain group TfsAdmins and I have no problem accessing reports in any tfs project. The same goes for any other members in that group.

     

    The problem occurs when the users in the domain groups TfsProjectOneContributors or TfsProjectOneUsers try to access reports (same goes for any users that are not administrators). They all get an error message stating:

     

    “The permissions granted to user 'DOMAIN\UserName' are insufficient for performing this operation. (rsAccessDenied)”

     

    Now, this error message is fairly well described but almost every solution work towards that you don’t have any permission set in Reporting Services. I have my user groups defined in RS and I have tied them to different roles.

     

    I don’t want the users of TfsProjectOne to be able to read data from any other project.

     

    These are the settings on my Reporting Services:

     

    http://server/Reports/

    Root

    BUILTIN\Administrators                  Content Manager

    DOMAIN\TfsAdmins                        Content Manager

     

    Project one

    BUILTIN\Administrators                  Content Manager

    DOMAIN\TfsAdmins                        Content Manager

    DOMAIN\TfsProjectOneAdmin               Report Builder

    DOMAIN\TfsProjectOneContributors        Publisher

    DOMAIN\TfsProjectOneUsers               Browser

     

    Project two

    BUILTIN\Administrators                  Content Manager

    DOMAIN\TfsAdmins                        Content Manager

    DOMAIN\TfsProjectTwoAdmin               Report Builder

    DOMAIN\TfsProjectTwoContributors        Publisher

    DOMAIN\TfsProjectTwoUsers               Browser

     

    My data sources look like this (I haven’t changed any settings from when TFS was installed):

     

    TfsReportDS

    (Checked) Enable this data source.

    Connection type: Microsoft SQL Server

    Connection string: Data source=ServerName;initial catalog=TFSWarehouse

    Connect using: Credentials stored securely in the report server

    Username: DOMAIN\SVC-TFSREPORTS

    Password: ********

    (Checked) Use as Windows credentials when connecting to the data source

    BUILTIN\Administrators                  Content Manager

    DOMAIN\TfsAdmins                        Content Manager

     

    TfsOlapReportDS

    (Checked) Enable this data source.

    Connection type: Microsoft SQL Server Analysis Services

    Connection string: Data source=ServerName;initial catalog=TFSWarehouse

    Connect using: Credentials stored securely in the report server

    Username: DOMAIN\SVC-TFSREPORTS

    Password: ********

    (Checked) Use as Windows credentials when connecting to the data source

    BUILTIN\Administrators                  Content Manager

    DOMAIN\TfsAdmins                        Content Manager

     

     

    I wasn’t a part of setting up the system, someone else installed TFS and all the bits and pieces so I can’t actually tell for sure if anything was changed or not from out-of-the box. But I can tell for sure that my users can’t access any reports.

     

    I tried to change the data source to use “Windows integrated security” and I tried to check “Impersonate the authenticated user after a connection has been made to the data source” but that won’t work either…

     

    Does anyone have any ideas on how to solve this? Everything else works fine with TFS and WSS for my users, it’s just the reports they can’t get.

     

    Regards,

    Tobias Nyberg

     

    Monday, January 29, 2007 4:25 PM

Answers

All replies

  • Hey Tobias,

    Have you found a solution?  Try taking a look at this thread and see if Thomas' solution helps you:

    https://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=1158068&SiteID=1

    mauli

    Monday, February 19, 2007 8:30 PM
  • Tuesday, April 24, 2007 10:17 AM
  •  

    Hi,

    Even i had received this error.

    I checked the project Properties

    Check for TargetDataSource,TargetReportFolder and TargetServerURL . You must have right for these folder and they must exist at the server

     

    Regards

    Sushma Nair B

    India

    Tuesday, November 27, 2007 10:52 AM
  •  

    Go to IIS and on your Reporting Server folder properties/Directory Security and then remove the permission for Anonymous Users and go with Integrated Security
    • Proposed as answer by laurensp Monday, May 3, 2010 3:57 PM
    Friday, July 25, 2008 11:05 AM
  •  

    Go to IIS and on your Reporting Server folder properties/Directory Security and then remove the permission for Anonymous Users and go with Integrated Security

    This totally worked for me. Thank you!
    Monday, August 10, 2009 9:18 AM
  • OK...  If you or any else is running into this issue in server 2008 you may not have set yourself up in Report Manager with the proper roles because you didn't see the properties tab in Report Manager.  You need to run IE as administrator (right click IE icon) to see this even if you are a local admin.  I don't know why but this worked for me.
    • Proposed as answer by Code_Drone Wednesday, March 10, 2010 11:53 AM
    Monday, February 1, 2010 9:49 PM
  • OK...  If you or any else is running into this issue in server 2008 you may not have set yourself up in Report Manager with the proper roles because you didn't see the properties tab in Report Manager.  You need to run IE as administrator (right click IE icon) to see this even if you are a local admin.  I don't know why but this worked for me.
    This worked for me.  For some reason I was unable to see anything until I ran IE as Administrator...I love Windows.
    Monday, March 15, 2010 4:40 PM
  • OK...  If you or any else is running into this issue in server 2008 you may not have set yourself up in Report Manager with the proper roles because you didn't see the properties tab in Report Manager.  You need to run IE as administrator (right click IE icon) to see this even if you are a local admin.  I don't know why but this worked for me.
    This worked for me.  For some reason I was unable to see anything until I ran IE as Administrator...I love Windows.


    This worked for me also.

    Im running Server 2008 as well.

    Wednesday, June 2, 2010 4:08 PM
  • At last, I just tried running IE as administrator and it works!!

    I have been searching for this solutions for ages! Why is it the solution to Windows is so simple, if only you can find it!! 

    Thursday, September 2, 2010 6:14 AM
  • Yes, sorted for this SQL2008R2 server. What a terrible use of UAC - it does mention it on the error message but combined with now hiding SSRS sites on the IIS console, the whole connection setup is badly documented regarding this. I use Firefox because IE was slow, and even when switching back (back of mind reminded me of proprietry requirements), how are you supposed to know to run it as Admin on top of having all the admin (local and domain) permissions? And why not just say on the error "you must run this browser as admin", not "blah blah check UAC blah blah". Timewasting again, making your reselling ISV's get frustrated and bankrupt and not encouraging new users to move to SSRS. Sort it out MS SQL team!

    Friday, October 22, 2010 3:22 PM
  • Euro - your answer should be the real solution!!
    MMayo
    Friday, December 3, 2010 4:47 PM
  • Thanks a lot i save my time.

    Server 2008 R2


    Christopher - |MCP Windows XP |MCITP:Server Administrator,Database Administrator,Ax2009 Installation & Configuration| CCNA ....
    Wednesday, January 19, 2011 11:10 AM
  • That's worked for me. Thanks!...
    Monday, April 25, 2011 10:06 AM
  • I've installed SSRS2012 syde-by-side to SSRS2008R2.
    Under SSRS2008R2 I use rs.exe to start report with store in excel.
    Due to 256 column limitation i have try to use SSRS2012.

    I got next error:

    -----Try to start rs.FireEvent(TimedSubscription)
    !!!!!!!!!!!!!!!!!Got an Exception System.Web.Services.Protocols.SoapException: T
    he permissions granted to user 'box\myAccount' are insufficient for performing this operation. ---> Microsoft.ReportingServices.Diagnostics.Utilities.AccessDeniedException: The permissions granted to user 'box\myAccount' are insufficient for performing this operation.
       at Microsoft.ReportingServices.Library.ReportingService2005Impl.FireEvent(Str
    ing EventType, String EventData, Guid batchId)
       at Microsoft.ReportingServices.WebServer.ReportingService2005.FireEvent(Strin
    g EventType, String EventData)

    the match information in log:
    library!ReportServer_0-2!1ed8!11/01/2012-13:54:51:: i INFO: Call to FireEventAction(TimedSubscription, <>, ).
    library!ReportServer_0-2!1ed8!11/01/2012-13:54:51:: e ERROR: Throwing Microsoft.ReportingServices.Diagnostics.Utilities.AccessDeniedException: , Microsoft.ReportingServices.Diagnostics.Utilities.AccessDeniedException: The permissions granted to user 'WIN-5PRKSLBIC68\soften3' are insufficient for performing this operation.;

    All security settings completed - user, folder - match to SSRS2008
    it is possible that issue in IIS authorization  - but there is HTTP.SYS!!!!!!

    What way i can fix this issue?

    Thanks

    Thursday, November 1, 2012 8:10 PM

  • The main problem was, with SCHEMA CONFLICTS.

    First identify which fields are causing schema conflicts, invoke GetWarehouseStatus and observe the XML which fields got conflicted, and in which collection. once you found the filed names then rename the fields with the help of below link.


    http://geekswithblogs.net/Natalia/Default.aspx

    http://msdn.microsoft.com/en-us/library/ee921480(v=VS.100).aspx


    then rebuild your warehouse from tfs admin console, take a back up of old database in sql database and delete it .wait for some time (depends on warehouse time to refresh the cube  or check the GetWarehouseStatus next day and check the xml ). to check this use below link

    http://localhost:8080/tfs/TeamFoundation/Administration/v3.0/WarehouseControlService.asmx?op=GetProcessingStatus

    I spend lot of time to resolve this issue, that's why posting the solution here, this may help some one... any queries related schema conflicts and Reporting services feel free to post me... iam not a expert but for sure i can help you out in this issues.... 

    Please use Mark as Answer if my post solved your problem and use Vote As Helpful if a post was useful.
    Monday, June 10, 2013 9:33 AM