none
Can't connect to Azure File Storage using "net use" command - System error 2148073478

    Question

  • After the update of Azure File storage sept. 28/29 2015 I am no longer able to connect to my Azure File Storage, from my Azure Windows Server 2012R2 virtual machine.

    I try to connect and map the File storage as network drives using the "net use" command.

    cmdkey /add:<storage-account-name>.file.core.windows.net /user:<storage-account-name> /pass:<storage-account-key>
    net use <drive-letter>: \\<storage-account-name>.file.core.windows.net\<share-name>

    But i get the error message:

    CMDKEY: Credential added successfully.
    net : System error 2148073478 has occurred.
    At C:\BackupScripts\Map networkdrives.ps1:5 char:1
    + net use Y: \\<storage-account-name>.file.core.windows.net\<share-name>
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (System error 2148073478 has occurred.:String) [], RemoteException
        + FullyQualifiedErrorId : NativeCommandError

    However I am perfectly able to connect to the File storage using the exact same command from my on-premises Windows 10 machine.

    I have already tried the 'Disable "Secure Negotiate" on the client' workaround described in https://support.microsoft.com/en-us/kb/2686098 But that didn't solve the problem.

    UPDATE (FIXED)

    I have resolved the problem by rebooting the machine, even though it wasn't nice to reboot the production environment, it solved the problem.

    • Edited by KimKnutzen Wednesday, September 30, 2015 8:13 PM
    Wednesday, September 30, 2015 9:59 AM

Answers

  • Hi Girish Prajwal

    Now when it's evening I took the freedom to reboot the virtual machines, even though it wasn't nice to reboot the production environment. However it did solve the problem. And I was able to connect the network drive.

    I have tried to turn on "Secure Negotiate" again be running the command

    Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters" 
    RequireSecureNegotiate -Value 1 -Force

    Can you verify that it's correct to turn it on, by setting the value to 1?

    Kim Knutzen


    Wednesday, September 30, 2015 8:11 PM

All replies

  • Hi,

    Thanks for posting here.

    As you have already tried to Disable the "Secure Negotiate" option the client which is the only workaround available for this issue now, I suggest you to try once more to disable & check if you are able to get it work.

    Meanwhile, I will try to check with concerned team in here to get another other workaround if possible for this issue.

    Hope this helps you.

    Girish Prajwal

    Wednesday, September 30, 2015 5:12 PM
    Moderator
  • Hi Girish Prajwal

    Now when it's evening I took the freedom to reboot the virtual machines, even though it wasn't nice to reboot the production environment. However it did solve the problem. And I was able to connect the network drive.

    I have tried to turn on "Secure Negotiate" again be running the command

    Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters" 
    RequireSecureNegotiate -Value 1 -Force

    Can you verify that it's correct to turn it on, by setting the value to 1?

    Kim Knutzen


    Wednesday, September 30, 2015 8:11 PM