locked
avi problem RRS feed

  • Question

  • avi problem

    I have some avi files which play with no problems....with windows media player

    but when I try to play them within vbe 2008 using windows media player......vshost stops them from playing

    windows tells me that data execution prevention  ....dep is turned on to prevent damage to my files....

    I am using vista

     

    any advice..???

     

    Sunday, February 3, 2008 11:56 AM

Answers

  • http://support.microsoft.com/kb/875352

    Per-program DEP configuration

    For the purposes of program compatibility, you can selectively disable DEP for individual 32-bit programs when DEP is set to the OptOut policy level. To do this, use the Data Execution Prevention tab in System Properties to selectively disable DEP for a program. For IT professionals, a new program compatibility fix that is named DisableNX is included with Windows XP SP2. The DisableNX compatibility fix disables Data Execution Prevention for the program that the fix is applied to.

    The DisableNX compatibility fix can be applied to a program by using the Application Compatibility Toolkit. For more information about Windows application compatibility, see Windows Application Compatibility on the following Microsoft Web site:

     
    I don't know about visa but on XP it is control Panel - system - advanced tab - performance settings button - Data execution prevention tab
     
    Also this page may help
     
     

    The "COM surrogate has stopped working" error that is sometimes received in Windows Vista while viewing media folders can be corrected by turning off DEP for the dllhost.exe. This error surfaces in Windows Vista because many video and audio codecs are not completely compatible with the new Operating System. This problem may also generally be resolved by updating any installed codecs to their latest versions.

     

    Or try at own risk

     

    http://www.realtime-vista.com/administration/2007/04/disabling_data_execution_preve.htm

     

    Disabling Data Execution Prevention (DEP)

    Sunday, February 3, 2008 12:14 PM

All replies

  • http://support.microsoft.com/kb/875352

    Per-program DEP configuration

    For the purposes of program compatibility, you can selectively disable DEP for individual 32-bit programs when DEP is set to the OptOut policy level. To do this, use the Data Execution Prevention tab in System Properties to selectively disable DEP for a program. For IT professionals, a new program compatibility fix that is named DisableNX is included with Windows XP SP2. The DisableNX compatibility fix disables Data Execution Prevention for the program that the fix is applied to.

    The DisableNX compatibility fix can be applied to a program by using the Application Compatibility Toolkit. For more information about Windows application compatibility, see Windows Application Compatibility on the following Microsoft Web site:

     
    I don't know about visa but on XP it is control Panel - system - advanced tab - performance settings button - Data execution prevention tab
     
    Also this page may help
     
     

    The "COM surrogate has stopped working" error that is sometimes received in Windows Vista while viewing media folders can be corrected by turning off DEP for the dllhost.exe. This error surfaces in Windows Vista because many video and audio codecs are not completely compatible with the new Operating System. This problem may also generally be resolved by updating any installed codecs to their latest versions.

     

    Or try at own risk

     

    http://www.realtime-vista.com/administration/2007/04/disabling_data_execution_preve.htm

     

    Disabling Data Execution Prevention (DEP)

    Sunday, February 3, 2008 12:14 PM
  • THANKS BD

    as disabling dep is not recommended, I think I'll omit the avi files from project

    thanks for the info

    clint

    Sunday, February 3, 2008 12:56 PM
  • I am not using vista I use XPMCE 2005 I don't have that problem I can play avi files from VBE 2008 so I guess it is a Vista issue .

    Sunday, February 3, 2008 1:30 PM
  • yeah, I guess so

    I have just noticed...it says the problem is caused by... xvid..

    so Maybe I could convert xvid to mpg....if I can find a converter

    or just turn off dep for xvid....

    thanks again

    clint

    Sunday, February 3, 2008 1:42 PM