locked
Manage group (add/delete users) without being able to delete the group. RRS feed

  • Question

  • I hope there is something very obvious that I'm missing.  I am the site owner and designer.  I want one of my "Super Users" ​to manage the addition/removal of persons on the groups...but I do not want the SU to have the ability to delete any groups.  So in effect I do not want to make my SU a Site Owner (or Group Owner) ..that is too much permission and responsibility to place on her as she's not an IT person.  

    I thought I was close ... I went to:

    Site Actions / Site Site Settings

    Site Members / Settings / Group Settings

    From there I have options: Owner and Group Settings 

    Owner allows adding/removing members and DELETING the group.

    Group Settings provides the ability to only add/remove members from the group.  This is what I want...but the only options are Group Owner and Group Members .... radio boxes...not a people picker which is what I'd hoped for.

    I don't want Group Owner because I don't want delete access to the group ...

    I don't want Group Members as I don't want members of the group to be able to manage each other.  I kind of need a third option which would allow me to select a name or group that has the ability to add/remove members from the group..but not the ability to delete the group.

    Seems like a catch 22.  

    Please advise,

    Thx,


    ER


    • Edited by WERoberts Monday, August 6, 2012 8:11 PM
    Monday, August 6, 2012 8:09 PM

All replies

  • Sorry, but there is no third option.  As you have found if you make them Group owner then they can delete the group.  But if you allow Group Members the ability to add/remove users then anyone in the group can do it.  I don't know of any way to give add/remove to someone without also giving them the ability to delete the group.

    Paul Stork SharePoint Server
    MVP Senior Solutions Architect: BlueChip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    Monday, August 6, 2012 8:37 PM