locked
Visual Studio activation error RRS feed

  • Question

  • User47146 posted

    I am not able to connect to Xamarin from Visual Studio. What should I do?

    My company purchased several Xamarin licenses for the team, but I get an error when I try to login with Visual Studio.

    1. I open the XamarinStore.sln with Visual Studio 2013 or Visual Studio 2012 (tried both)
    2. "Using Xamarin.iOS with Visual Studio requires Business edition or higher. Please log in with your Xamarin account to proceed."
    3. I enter in my email address and password then click "Log In"
    4. I then get a Windows authorization dialog (like the one you get from Internet Explorer) titled "Connect to auth.xamarin.com" with the
    5. text "Connecting to auth.xamarin.com" asking me for User name and Password.
    6. I try to enter the same credentials from step 3 into this dialog box and click OK.
    7. Goto step 4. This repeats infinitely until I click cancel.
    8. Xamarin displays a dialog box titled "Unhandled Activation Error" with the text "There was an internal error in the activation system. Please contact Xamarin Support with the following error information."

    System.Net.WebException: The remote server returned an error: (401) Unauthorized. at System.Net.HttpWebRequest.GetResponse() at Xamarin.Components.Ide.Web.RequestHelper.GetResponse(Func1 createRequest, Action1 prepareRequest, CancellationToken token) at Xamarin.Components.Ide.SSO.Client.DoRequest(String endpoint, String method, String body, CancellationToken cancellationToken) at Xamarin.Components.Ide.SSO.Client.CreateToken(String email, String password, CancellationToken cancellationToken) at Xamarin.Components.Ide.SSO.Client.<>cDisplayClass5.b4() at System.Threading.Tasks.Task`1.InnerInvoke() at System.Threading.Tasks.Task.Execute()

    Here is what I know that might help: - Windows 7, 64-bit. VS 2010, 2012, and 2013 Update 1 installed. 12GB RAM. - The corporate network uses a proxy server - The corporate proxy servers do a MITM attack on secure connections and present a fake certificate, which is added to the trusted certificate store on our machines.

    Is it possible that the second dialog that pops up in step 3 really wants my domain credentials? But that is strange and I do not want to enter them and risk sending them outside the network. Windows should automatically provide those credentials when an application connects to the proxy server. In no other case have I ever been asked for those credentials.

    I attached screen shots showing the process.

    Wednesday, April 9, 2014 9:15 PM

All replies

  • User47146 posted

    I discovered a bugzilla entry describing this problem:
    https://bugzilla.xamarin.com/show_bug.cgi?id=11095
    And another forum discussion on it:
    http://forums.xamarin.com/discussion/3257/xamarin-studio-is-unable-to-get-updates-or-download-components-when-behind-a-corporate-proxy

    Tuesday, April 15, 2014 3:53 PM
  • User28 posted

    Step 4 is requesting the credentials for your proxy server, not for Xamarin. We'll look into making this clearer. We'll also look into why this is happening for domain-based proxy auth, which should be automatic.

    Saturday, April 19, 2014 6:35 PM
  • User48937 posted

    so am i,mhutch please help me :(

    Tuesday, April 22, 2014 6:07 PM
  • User48935 posted

    Can someone help with this Unhandled Activation Error w/VS2012 ultimate

    using v4.2.3 free download

    here is the error msg: System.Net.WebException: The remote server returned an error: (500) Internal Server Error. at Xamarin.Components.Ide.Activation.ActivationService.GetErrorWorkflow(LicenseSyncResult[] results, Boolean ignoreSyncErrors) at Xamarin.Components.Ide.Activation.ActivationService.d88.MoveNext() at Xamarin.Components.Ide.Activation.ActivationDialog.DisplayWorkflowStep(ActivationWorkflowStep step) at Xamarin.Components.Ide.Activation.ActivationDialog.<>cDisplayClass13.b__12(Task t)

    Tuesday, April 22, 2014 8:10 PM
  • User44709 posted

    @ahmada? There appears to be a problem with the server: http://forums.xamarin.com/discussion/15934/not-able-to-log-in-to-xamarin-acccount-getting-please-connect-to-the-internet-to-proceed#latest

    Tuesday, April 22, 2014 8:14 PM
  • User18 posted

    Hi @ahmada!

    The issue mentioned in the thread that @PeterDavis posted should now be resolved. If you run into any further activation errors, please let us know!

    Tuesday, April 22, 2014 8:55 PM
  • User47146 posted

    A few updates on this:
    1) FWIW: I tried entering my domain login credentials into the dialog box and it did not work. I get the same result.
    2) The issue I am reporting isn't the same issue @ahmada referred to. Different error number, and the problem still persists today (May 2)
    3) Bug 11095 was resolved - how do I get an update with that fix in it? I am using Xamarin 4.2.4 (build 35).

    Friday, May 2, 2014 8:29 PM
  • User52240 posted

    After installing Xamarin for VS i cannot start visual studio 2012 or 2013. it crushes immediately. I cannot work with VS even for projects that are not related to Xamarin!!!!

    Wednesday, May 14, 2014 9:41 AM
  • User56574 posted

    I'm facing the same activation issue with 401 unauthorized access exception even with right proxy credentials

    Friday, June 6, 2014 1:55 PM
  • User102546 posted

    From time to time I still get this error and cannot do anything about it. Unhandled Activation Error

    There was an internal error in activation system. Please contact Xamarin Support with the following error information.

    System.Exception: Could not load machine data: at Xamarin.Components.Ide.Activation.ActivationService.GetErrorWorkflow(LicenseSyncResult[] results, Boolean ignoreSyncErrors) at Xamarin.Components.Ide.Activation.ActivationService.d89.MoveNext() at Xamarin.Components.Ide.Activation.ActivationDialog.DisplayWorkflowStep(ActivationWorkflowStep step) at Xamarin.Components.Ide.Activation.ActivationDialog.<>cDisplayClass13.b__12(Task t)

    And here is the screenshot with above error:

    Monday, March 9, 2015 4:01 PM
  • User116528 posted

    I get this error: Unhandled Activation Error

    There was an internal error in activation system. Please contact Xamarin Support with the following error information.

    System.Exception: Could not load machine data: at Xamarin.Components.Ide.Activation.ActivationService.GetErrorWorkflow(LicenseSyncResult[] results, Boolean ignoreSyncErrors) at Xamarin.Components.Ide.Activation.ActivationService.d89.MoveNext() at Xamarin.Components.Ide.Activation.ActivationDialog.DisplayWorkflowStep(ActivationWorkflowStep step) at Xamarin.Components.Ide.Activation.ActivationDialog.<>cDisplayClass13.b__12(Task t)

    Tuesday, March 24, 2015 12:08 PM
  • User149660 posted

    System.Exception: Could not load machine data: monodroid: missing -sdk-dir=DIRECTORY. at Xamarin.Components.Ide.Activation.ActivationService.GetErrorWorkflow(LicenseSyncResult[] results, Boolean ignoreSyncErrors) at Xamarin.Components.Ide.Activation.ActivationService.d88.MoveNext() at Xamarin.Components.Ide.Activation.ActivationDialog.DisplayWorkflowStep(ActivationWorkflowStep step) at Xamarin.Components.Ide.Activation.ActivationDialog.<>cDisplayClass13.b__12(Task t)

    Tuesday, September 22, 2015 8:50 AM