none
setting up azure media player on wordpress RRS feed

  • Question

  • Hi,

    Can someone please help me with this, I have added this code to header.

    <link href="//amp.azure.net/libs/amp/latest/skins/amp-default/azuremediaplayer.min.css" rel="stylesheet">
    <script src= "//amp.azure.net/libs/amp/latest/azuremediaplayer.min.js"></script>

    But i don't know what to do next, I am serving my media from azure cdn and i want those media files to be served with the azure media player. I use wordpress, When i embed media to post from media library, It is served from azure cdn but uses the default wordpress media, How do i make my embedded videos use azure media player?

    Thanks,

    Sunday, June 9, 2019 8:33 PM

All replies

  • According to http://amp.azure.net/libs/amp/latest/docs/index.html the next thing to do is to insert the player code within the <body> tag.  Something similar to:

    <video id="vid1" class="azuremediaplayer amp-default-skin" autoplay controls width="640" height="400" poster="poster.jpg" data-setup='{"nativeControlsForTouch": false}'>
        <source src="http://amssamples.streaming.mediaservices.windows.net/91492735-c523-432b-ba01-faba6c2206a2/AzureMediaServicesPromo.ism/manifest" type="application/vnd.ms-sstr+xml" />
        <p class="amp-no-js">
            To view this video please enable JavaScript, and consider upgrading to a web browser that supports HTML5 video
        </p>
    </video>

    And then you'd just change the link to your own video in the src parameter.

    Monday, June 10, 2019 3:41 PM
    Moderator