"Invalid Cast Exception" during restore RRS feed

  • Question

  • Hello All (Warning EXTREME newbie here),

    We are using CommVault to perform backups of our SharePoint 2013 site.

    Today, we tried a backup/restore test to make sure that we could successfully perform such an operation.

    We had a a sub-site that contained a list (with six items),  some documents in a library, along with a page to expose the list and  a page to expose the document library.

    After our backup, I deleted the list, and two documents. 

    We were able to restore the documents that were deleted successfully.

    Our next test involved trying to restore a single item from the deleted list. This failed with an "invalid cast" exception. Next we tried to restore the entire list and got the same "invalid cast exception". We were unable to restore the entire sub-site as well.

    But, we were able to restore the entire site if we excluded the list from the restore job.

    So...  what causes an "invalid cast exception" during a restore (the error is thrown immediately after the Manifest.XML file is created (per the CommVault logs).  Is that occurring on the CommVault side? or on the SharePoint side? (I suspect that this is happening on the SharePoint side).

    Thanks for any insights.

    Friday, August 7, 2015 10:16 PM