locked
Windows 7 users using SPS 2003 are constantly being asked for password; documents are not opening correctly RRS feed

  • Question

  • I am seeing a lot of general issues relating to document usage on SharePoint 2003 and users in our company who have been upgraded to Windows 7.  Here are some of the issues I am seeing:

     

    • Users unable to open document directly from SP as they could before..they are being prompted to save the documents and then must open them manually after saving
    • Users being prompted for their user IDs and passwords when attempting to open documents repeatedly for the same document - the login doesn't work, but when the user cancels out the document appears as read-only

     

    • Edited by Mike Walsh FIN Thursday, July 15, 2010 3:20 AM Title improved
    Wednesday, July 14, 2010 5:00 PM

Answers

  • This is almost always a security zone issue.

    When your users were upgraded to Windows 7, they no doubt lost their security zone settings in IE for their sites.  Ensure that the IE security zone displayed when they're on the site in question is LOCAL INTRANET and the logon prompts should magically disappear. ;-)

     


    I trust that answers your question...

    Thanks
    C

    http://www.cjvandyk.com/blog
    • Marked as answer by Stanfford Liu Friday, July 23, 2010 6:53 AM
    Thursday, July 15, 2010 3:20 PM
    Answerer
  • Just to add a little more information to answer this query...

    I believe the reason you are getting the logon prompt is due to the fact that by default, persistent cookies are not shared between Internet Explorer and Office applications in Windows 7 (it uses the same security model as Vista in this respect). This is due to Windows "Protected Mode" which sets up an isolated cache location for "untrusted sites".

    Sites that are added to the "trusted sites" or "Local Intranet" zones use the regular cache - which hopefully means that cookies will be shared between IE and your office applications, preventing the need to re-authenticate.

    Note that in order for this to work you must leave protected mode disabled for your trusted sites and local intranet zones.

    KB: http://support.microsoft.com/kb/932118/en-us

    HTH.


    Benjamin Athawes
    Twitter
    SharePoint Blog

    • Marked as answer by Stanfford Liu Friday, July 23, 2010 6:53 AM
    Thursday, July 15, 2010 6:03 PM

All replies

  • This is almost always a security zone issue.

    When your users were upgraded to Windows 7, they no doubt lost their security zone settings in IE for their sites.  Ensure that the IE security zone displayed when they're on the site in question is LOCAL INTRANET and the logon prompts should magically disappear. ;-)

     


    I trust that answers your question...

    Thanks
    C

    http://www.cjvandyk.com/blog
    • Marked as answer by Stanfford Liu Friday, July 23, 2010 6:53 AM
    Thursday, July 15, 2010 3:20 PM
    Answerer
  • Just to add a little more information to answer this query...

    I believe the reason you are getting the logon prompt is due to the fact that by default, persistent cookies are not shared between Internet Explorer and Office applications in Windows 7 (it uses the same security model as Vista in this respect). This is due to Windows "Protected Mode" which sets up an isolated cache location for "untrusted sites".

    Sites that are added to the "trusted sites" or "Local Intranet" zones use the regular cache - which hopefully means that cookies will be shared between IE and your office applications, preventing the need to re-authenticate.

    Note that in order for this to work you must leave protected mode disabled for your trusted sites and local intranet zones.

    KB: http://support.microsoft.com/kb/932118/en-us

    HTH.


    Benjamin Athawes
    Twitter
    SharePoint Blog

    • Marked as answer by Stanfford Liu Friday, July 23, 2010 6:53 AM
    Thursday, July 15, 2010 6:03 PM