locked
error: 8007007e RRS feed

  • Question

  • User67684766 posted

    Hey Everyone,

    Have crawled through the forums but cannot find a definite answer for this:

    Have a crystal report running through crystal viewer, runs fine locally, publish to my internal server (Windows Server 2003 32bit) and the report runs fine

    But, when I publish it to my web server (Windows server 2003 64bit R2) I get the below error:

    I have run the Crystal Distribution/Runtime files etc, but still no luck

     

    Retrieving the COM class factory for component with CLSID {5FF57840-5172-4482-9CA3-541C7878AE0F} failed due to the following error: 8007007e.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.IO.FileNotFoundException: Retrieving the COM class factory for component with CLSID {5FF57840-5172-4482-9CA3-541C7878AE0F} failed due to the following error: 8007007e.

    Source Error:

    Line 8:      AutoDataBind="True" Height="1119px" ReportSourceID="CrystalReportSource1" 
    Line 9:          Width="875px" />
    Line 10:     <CR:CrystalReportSource ID="CrystalReportSource1" runat="server">
    Line 11:         <Report FileName="Report.rpt">
    Line 12:         </Report>

    Stack Trace:

    [FileNotFoundException: Retrieving the COM class factory for component with CLSID {5FF57840-5172-4482-9CA3-541C7878AE0F} failed due to the following error: 8007007e.]
       CrystalDecisions.CrystalReports.Engine.ReportDocument..cctor() +207
    
    [TypeInitializationException: The type initializer for 'CrystalDecisions.CrystalReports.Engine.ReportDocument' threw an exception.]
       CrystalDecisions.CrystalReports.Engine.ReportDocument..ctor() +0
       CrystalDecisions.ReportSource.CachedReport.get_ReportDocument() +39
       CrystalDecisions.Web.CrystalReportSource.set_Report(Report value) +219
       ASP.competitorenquiry_aspx.__BuildControlCrystalReportSource1() in C:\Enquiry.aspx:10
       ASP.competitorenquiry_aspx.__BuildControlContent3(Control __ctrl) in C:\Enquiry.aspx:6
       System.Web.UI.CompiledTemplateBuilder.InstantiateIn(Control container) +12
       ASP.gaa_master.__BuildControlMainBody() in master.Master:42
       ASP.gaa_master.__BuildControlform1() in master.Master:17
       ASP.gaa_master.__BuildControlTree(gaa_master __ctrl) in C:\Master.Master:1
       ASP.gaa_master.FrameworkInitialize() +44
       System.Web.UI.UserControl.InitializeAsUserControlInternal() +35
       System.Web.UI.MasterPage.CreateMaster(TemplateControl owner, HttpContext context, VirtualPath masterPageFile, IDictionary contentTemplateCollection) +8664863
       System.Web.UI.Page.get_Master() +51
       System.Web.UI.Page.ApplyMasterPage() +15
       System.Web.UI.Page.PerformPreInit() +45
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +282
    

    Any help would be much appreciated,

    Thanks in advance

    Paul
     

    Tuesday, February 8, 2011 5:54 PM

All replies

  • User-1528094326 posted

    Error means  that the component your trying to use is not registered or is missing. If its happening with Crystal reports then you'll need to perform regsvr32 <dll name here> to re-register them. Or you can reinstall the neecessary components and that will probably fix it too.

    Tuesday, February 8, 2011 7:08 PM
  • User67684766 posted

    Thanks for the reply Scott

    I re-ran the Crystal Dist files and I think running the 64bit version of the Crystal Dist, solved part the problem

    and I got a step further now

    and it gave me a new error 'Load Report Failed'

    So I applied additional ASPNET/IIS permissions to the Folders/Files/Reports


    Now i'm a step further again

    I don't get a server error
    Instead the CrystalViewer starts to load in the browser on the correct page

    But where the parameter page should appear I get the below

    ---------------------------------------------------------------------------------------------------------------------------------------------------------
    ---------------------------------------------------------------------------------------------------------------------------------------------------------

    Cheers
    Paul

    Wednesday, February 9, 2011 8:03 AM
  • User-2090712146 posted

    hi , I had the same problem so I fixed mine by uninstalling and reinstalling CRRuntime 32 bit .

    Thursday, November 5, 2015 5:40 AM