locked
Page controls not painting properly when returning from 'Snapped' view

    Question

  • I have had this problem before, but it seemed to disappear at some point but now it is back.  When I switch my app to 'Snapped' view where it is displayed as a narrow column on the right, I display a page which has a single button which, when pressed, will call 'TryUnsnap' to return to the 'Filled' mode, which it does.  However sometimes some controls that I have on the right are not redrawn properly.  The following image is how it should look:

    http://gabytest.com/test/unsnapped-good.jpg

    Notice the buttons on the right.  However, sometimes when I unsnap (only about 20% of the time) I get the following

    http://gabytest.com/test/unsnapped-bad.jpg

    Now the buttons appear to be missing on the right, but they are still there and if I click on them they do redraw properly.

    Can anyone give me a clue as to why these are sometimes not repainting correctly.  Is there a function that I can call that will force them to repaint?

    Note also that I only see this happening when I run the app on a PC.  I have never seen it happen when running on an (arm based) tablet.

    Thanks.


    Friday, June 14, 2013 3:02 AM

All replies

  • After further investigation it also appears that this only happens if I run the app on the secondary monitor attached to my PC.  When I run it on the primary monitor, I cannot seem to get it to happen at all.  Is this possibly a bug with handling 2 monitors?

    Thanks.

    Friday, June 14, 2013 4:01 AM
  • This sounds like a video driver problem. Do you have the latest video drivers on the problem system? Does it occur on other types or just the one?
    Friday, June 14, 2013 2:17 PM
    Owner