locked
Cannot uninstall VS Premium 2013 with Blend on Windows 8 RRS feed

  • Question

  • Hi Guys,

    I have been having a hard time trying to uninstall/repair my VS Premium installation.

    My system;

    Windows 8.1 Pro - 64 x

    Intel i5-4210M CPU @ 2.60 GHZ

    The error;

     

      Fatal error during installation.

            PreEmptive Analytics Visual Studio Components

    Package failed. 

    Microsoft Visual Studio 2013 Performance Collection Tools

    Package Failed

    [02A0:24D4][2015-06-30T08:22:32]i301: Applying execute package: PreEmptiveAnalytics_298, action: Uninstall, path: (null), arguments: ' ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7"'
    [2634:1D24][2015-06-30T08:22:33]i000: MUX:  ExecuteError: Package (PreEmptiveAnalytics_298) failed: Error Message Id: 1402 ErrorMessage: Error 1402.Could not open key: HKEY_LOCAL_MACHINE32\SYSTEM\CurrentControlSet\Services\EventLog\PreEmptive\PreEmptiveAnalytics.   Verify that you have sufficient access to that key, or contact your support personnel.
    [02A0:24D4][2015-06-30T08:22:33]e000: Error 0x80070643: Failed to uninstall MSI package.


    [02A0:24D4][2015-06-30T08:22:33]i301: Applying execute package: dynamicanalysiscollectionbits_482, action: Uninstall, path: (null), arguments: ' MSIFASTINSTALL="7" USING_EXUIH="1" VS7.3643236F_FC70_11D3_A536_0090278A1BB8="C:\Program Files (x86)\Microsoft Visual Studio 12.0"'
    [2634:1D24][2015-06-30T08:22:33]i000: MUX:  ExecuteError: Package (dynamicanalysiscollectionbits_482) failed: Error Message Id: 1402 ErrorMessage: Could not open key: HKEY_LOCAL_MACHINE32\SYSTEM\CurrentControlSet\Services\EventLog\Application\Visual Studio Profiler.   Verify that you have sufficient access to that key, or contact your support personnel.
    [02A0:24D4][2015-06-30T08:22:34]e000: Error 0x80070643: Failed to uninstall MSI package.
    [02A0:24D4][2015-06-30T08:22:34]e000: Error 0x80070643: Failed to execute MSI package.
    [2634:1D24][2015-06-30T08:22:34]e000: Error 0x80070643: Failed to configure per-machine MSI package.

    [2634:1D24][2015-06-30T08:22:42]w348: Application requested retry of package: vs_premiumcore, encountered error: 0x80070643. Retrying...
    [02A0:24D4][2015-06-30T08:22:42]i301: Applying execute package: vs_premiumcore, action: Uninstall, path: (null), arguments: ' ARPSYSTEMCOMPONENT="1" MSIFASTINSTALL="7" VSEXTUI="1" VS7.3643236F_FC70_11D3_A536_0090278A1BB8="C:\Program Files (x86)\Microsoft Visual Studio 12.0" PIDKEY="37F2VHH3GCWYQTRT3GQGTY94H"'
    [2634:1D24][2015-06-30T08:22:44]i000: MUX:  ExecuteError: Package (vs_premiumcore) failed: Error Message Id: 1402 ErrorMessage: Error 1402.Could not open key: HKEY_LOCAL_MACHINE32\SYSTEM\CurrentControlSet\Services\EventLog\Application\Microsoft Test Manager.

    Why is the uninstaller looking for a registry (HKEY_LOCAL_MACHINE32), which does not exist. And, HKEY_LOCAL_MACHINE32? wait, what?

    Any help would be greatly appreciated as I am trying to avoid a reinstall on windows.

    Kev


    Kind Regards, Kevin Heathfield Cape Town, South Africa, ^5

    Tuesday, June 30, 2015 6:49 AM

Answers

  • Hi Kevin Heathfield,

    >> [2634:1D24][2015-06-30T08:22:44]i000: MUX:  ExecuteError: Package (vs_premiumcore) failed: Error Message Id: 1402 ErrorMessage: Error 1402.Could not open key: HKEY_LOCAL_MACHINE32\SYSTEM\CurrentControlSet\Services\EventLog\Application\Microsoft Test Manager.

    The registry on your machine is missing, and I found the error code “0x80070643” in your log, it means “Fatal error during installation”, this is a general error and most of the time, it means that your package was corrupted. So we need to repair your visual studio first, do you have the installation media?

    If you have it, please insert it and Repair it.

    If you don’t have the ISO image, please re-download it from here: http://download.microsoft.com/download/D/B/D/DBDEE6BB-AF28-4C76-A5F8-710F610615F7/VS2013_RTM_PREM_ENU.iso

    After download it, we need to make sure that this package is good, please use the FCIV.exe to verify the ISO checksum, refer to: https://support.microsoft.com/en-us/kb/841290 By using it, you will get the SHA-1 value, please compare it with “8C170080B5C3260CEBC3BA3B1D85A3E55C1A2747”. After making sure the SHA-1 value is true, and then try to repair your visual studio from the ISO.

    If the repair doesn’t work, what about give another tool a try? It is Microsoft Fixit. It did work for Visual Studio 2013 in the previous case, download from here: https://support.microsoft.com/en-us/mats/program_install_and_uninstall

    At last, after repair and using the Fix It, try to use the /uninstall /force to uninstall the visual studio.

    Best Regards,

    Jiayi Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    • Marked as answer by Barry Wang Tuesday, July 7, 2015 10:45 AM
    Wednesday, July 1, 2015 3:31 AM

All replies

  • Hi,

    You can find similar discussion at the forum post here

    https://social.msdn.microsoft.com/Forums/en-US/93f8dc03-b92f-4029-b834-04f2bcaca841/microsoft-visual-studio-community-2013-with-update-4-uninstall?forum=vssetup

    Also you can try using an uninstaller like Advanced Uninstaller for uninstalling the VS.

     


    Ram.

    Tuesday, June 30, 2015 7:14 AM
  • Hi Ram,

    Thanks for the swift response, I clearly need to dust off my googling skills..

    Will take a look and see what I can do. (P.S: I have tried /uninstall /force)

    Thanks again,

    Kev



    Kind Regards, Kevin Heathfield, Johannesburg, South Africa, ^5

    Tuesday, June 30, 2015 7:21 AM
  • Hi Kevin Heathfield,

    >> [2634:1D24][2015-06-30T08:22:44]i000: MUX:  ExecuteError: Package (vs_premiumcore) failed: Error Message Id: 1402 ErrorMessage: Error 1402.Could not open key: HKEY_LOCAL_MACHINE32\SYSTEM\CurrentControlSet\Services\EventLog\Application\Microsoft Test Manager.

    The registry on your machine is missing, and I found the error code “0x80070643” in your log, it means “Fatal error during installation”, this is a general error and most of the time, it means that your package was corrupted. So we need to repair your visual studio first, do you have the installation media?

    If you have it, please insert it and Repair it.

    If you don’t have the ISO image, please re-download it from here: http://download.microsoft.com/download/D/B/D/DBDEE6BB-AF28-4C76-A5F8-710F610615F7/VS2013_RTM_PREM_ENU.iso

    After download it, we need to make sure that this package is good, please use the FCIV.exe to verify the ISO checksum, refer to: https://support.microsoft.com/en-us/kb/841290 By using it, you will get the SHA-1 value, please compare it with “8C170080B5C3260CEBC3BA3B1D85A3E55C1A2747”. After making sure the SHA-1 value is true, and then try to repair your visual studio from the ISO.

    If the repair doesn’t work, what about give another tool a try? It is Microsoft Fixit. It did work for Visual Studio 2013 in the previous case, download from here: https://support.microsoft.com/en-us/mats/program_install_and_uninstall

    At last, after repair and using the Fix It, try to use the /uninstall /force to uninstall the visual studio.

    Best Regards,

    Jiayi Li


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    • Marked as answer by Barry Wang Tuesday, July 7, 2015 10:45 AM
    Wednesday, July 1, 2015 3:31 AM