locked
Small Basic v0.3 is now Live!! RRS feed

  • General discussion

  • Go get it at http://smallbasic.com

    I want to thank everyone on this forums for all the great feedback, most of which have been incorporated into this release.  Please keep those feedback flowing.  We're always listening.

    Don't forget to check out the new features and bug-fixes on this new release!  http://blogs.msdn.com/smallbasic/


    • Edited by Vijaye Raji Wednesday, February 11, 2009 1:06 AM
    Tuesday, February 10, 2009 11:50 PM

All replies

  •  What tries to install from the Download button at http://smallbasic.com, says it is v.02
    ...and I am unable to access http://blogs.smallbasic.com/ , tells me "Internet Explorer cannot display the webpage"
    Wednesday, February 11, 2009 12:24 AM
  • It's possible that the cached install is being pulled.  On IE, please make sure you hit Ctrl+F5 to refresh the cache. 
    Wednesday, February 11, 2009 1:07 AM
  • I can confirm that going to the above link takes you to the MSDN DevLabs page where text is showing version 0.2. I downloaded it just to double check, and the new file is saying 0.2 as well. I clear my cache, and even tried it with two other browsers (ie, firefox, and opera all together) and all show the page as saying 0.2.
    Wednesday, February 11, 2009 3:18 AM
    Answerer
  • After updating Small Basic does not work! : (
    Since its launch an error (and the execution is terminated):


    Описание:
      Stopped working

    Сигнатура проблемы:
      Имя события проблемы:    CLR20r3
      Сигнатура проблемы 01:    sb.exe
      Сигнатура проблемы 02:    0.3.0.0
      Сигнатура проблемы 03:    498f8566
      Сигнатура проблемы 04:    mscorlib
      Сигнатура проблемы 05:    2.0.0.0
      Сигнатура проблемы 06:    48ead7c2
      Сигнатура проблемы 07:    2b51
      Сигнатура проблемы 08:    333
      Сигнатура проблемы 09:    MXYABJ2RSFG4UKNKGMSPJ2KFPMZXHCC5
      Версия ОС:    6.0.6001.2.1.0.768.3
      Код языка:    1049

    Прочтите заявление о конфиденциальности:
      http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0419


    Checked on the operating systems: Windows Vista Ultimate, Windows Vista Home Premium
    Wednesday, February 11, 2009 8:20 AM
  •  Oh dear, I have downloaded and installed v0.3 and it wont run at all. As soon as I try to run it I get the standard "Microsoft Small Basic has encountered a problem and needs to close...".
    I have tried uninstalling and reinstalling, making sure I re-booted, but no luck. Of course I didn't bother saving the previous version.

    OS XP Pro SP3 set up for UK.
    Wednesday, February 11, 2009 12:12 PM
  • Same here for me. SmallBasic crashing on start with a standart windows error.
    Windows Vista Home Premium + SP1, RUS
    Wednesday, February 11, 2009 12:54 PM
  • It works great for me (fully updated Windows XP) . Starts up faster, splash screen is nice. I really like the import/export feature.
    Wednesday, February 11, 2009 2:15 PM
  • OK Dink87522, but what are your operating system and regional settings?
    Oops XP of course, but it still might help to know your regional settings.
    • Edited by Stendec Wednesday, February 11, 2009 3:44 PM Didn't read post properly
    Wednesday, February 11, 2009 3:41 PM
  •  Both links work for me now and v.03 is working great too.
    Wednesday, February 11, 2009 4:18 PM
  • Oceania (Australia). 
    Wednesday, February 11, 2009 8:59 PM
  • How does the import and publish buttons work? What are they supposed to be doing (past the obvious verb definitions) and where does the program ID come from?
    Wednesday, February 11, 2009 9:55 PM
    Answerer
  • no openning   :( no starting

    windows Xp Sp3 + Portuguese Brasil

    Wednesday, February 11, 2009 9:56 PM
  • Got it, thanks to the bouncing ball demo. Is there a list of available imports somewhere?
    Wednesday, February 11, 2009 10:21 PM
    Answerer
  • No Coding Cat, the imports are not going to be cataloged anywhere.  You can share your program by its "id" and whoever you share it will be the ones who can view/run it.
    Wednesday, February 11, 2009 11:09 PM
  •  

    Small Basic v0.3 was corrected.

    Problem v.0.3 nonenglish os/Vista : Small Basic : DevLabs : MSDN Forums
    http://social.msdn.microsoft.com/Forums/en-US/smallbasic/thread/4e339b04-bb0f-4a93-a1f0-e453029b3546

    I cleared the cash of IE, -> reinstalled -> confirmed the correct start.
    (XP Pro SP3, Japanese)

    Initial archive : v0.3,   5,270KB
    Latest archive  : v0.3.1, 4,979KB

    I will confirm Vista of home tonight.

    Thank you for quickly corresponding, Vijaye !

    Thursday, February 12, 2009 12:41 AM
  • Just updated to 0.3.1 and it is still not starting. :( vista home premium sp1 with russian language.
    Thursday, February 12, 2009 9:32 PM
  • Problem solved. See thread "Installation Problem with v0.3?"
    Friday, February 13, 2009 11:39 AM
  • Sorry, I wasn't aware of this (I had some other work to complete last week).

    I'll try to update my Library for this new version. Hope you don't have changed too much your code's background :-)

    Regards,
    Fremy
    Fremy VB & C#
    Tuesday, February 24, 2009 9:39 AM