locked
DEP0800 Error in Visual Studio 2012 while deploying App

    Question

  • I am trying to deploy the sample JavaScript windows 8 app in Visual Studio 2012 express but get this error every time even the build is successful:

    Error 1 Error : DEP0800 : The required framework "F:\Program Files\Microsoft SDKs\Windows\v8.0\ExtensionSDKs\Microsoft.WinJS.1.0\1.0\Microsoft.WinJS.1.0.appx" failed to install. 
    Windows cannot install package Microsoft.WinJS.1.0 because this package requires a higher Windows version. The package requested Windows version 6.2 with AppModel version 1, while the current Windows version is 6.2 with AppModel version 0.

    Any way to solve this issue.

    Thanks in advance.

    Friday, October 12, 2012 12:30 PM

All replies

  • I am having exactly the same issue. I am using Windows 8 Release preview, I installed Visual Studio 2012. I am able to compile the sample C++ project but get the same error when deploying.
    Wednesday, October 24, 2012 7:08 PM
  • Are you using the final release build of Windows 8 or the Windows 8 Release Preview build?  If you are using the Release Preview build, you need to use the matching Visual Studio 2012 RC build, instead of the final Visual Studio 2012 build.
    Wednesday, October 24, 2012 7:45 PM