none
Visual Studio 2015 - Error: class not registered

    Question

  • Good afternoon

    I hope this is the right place for this query.  I'm new to SSAS and have the 2015 developer edition to work through a workbook i have purchased.  When i open a Dimension > Data Source View > Show Tables > [Select table] > OK, i'm getting error "Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)).

    I've spent the morning scouring the web and have install OWC.EXE for 2003 but this has not resolved the issue.  There are other solutions which i'm not technically qualified to understand and wondered if someone from the MSDN community could help or provide a more definitive answer.

    Windows 10, Office 2013, SQL Server 2016 Developer, VS 2015 Community.  The version of the cube is AdventureWorks2008R2.

    Many thanks.

    • Moved by Sunil Hurkadli Wednesday, September 14, 2016 8:58 AM Not Related to VSTS
    Tuesday, September 13, 2016 12:06 PM

Answers

  • Hi Weiwei

    I did a little more searching and chanced upon a 64-bit installation conflicting/using a 32-bit component:

    https://msdn.microsoft.com/en-gb/library/dn876712.aspx

    You can't run SSIS packages in 32-bit mode after you upgrade to SQL Server 2016 Release Candidate 1 (RC1)

    Issue and customer impact: You can't run SSIS packages in 32-bit mode after you upgrade to SQL Server 2016 Release Candidate 1 (RC1) from SQL Server 2012, SQL Server 2014, or an earlier Community Technology Preview (CTP) or Release Candidate (RC) version of SQL Server 2016. Trying to run a package in 32-bit mode fails with an unexpected exception or error. This problem occurs when you try to run a package by using the 32-bit version of dtexec.exe, and also when you try to run a package in the SSIS Catalog with the 32-bit runtime option enabled.

    This problem does not occur when you do a clean installation of SQL Server 2016 Release Candidate 1 (RC1).

    Workaround: To work around this issue, do the following things.

    1. Uninstall the earlier version of SQL Server.

    2. Do a clean installation of SQL Server 2016 Release Candidate 1 (RC1).

    3. Install the latest version of the SQL Server Data Tools (SSDT). To get SSDT,

    I had SS2008R2 installed which i took off after i'd installed SS2016.  So i took all instances of SS components off using control panel and then did a clean install of SS2016.  Everything is now working fine.

    Thanks for taking the time to respond to my original message.

    Regards

    David H-M

    Thursday, September 15, 2016 11:51 AM

All replies

  • Hi David H-M,

    Could you please provide the detailed steps about how do you create SSAS project in VS2015 and what operations do you do after project created? I will try reproduce this issue in my side to check whether this issue related to your VS installation or the operations.

    According to your machine environment, you are using SQL Server 2016 Developer. But the cube is AdventureWorks2008R2, which is supports SQL Server 2008 R2. Please create a custom SQL Server 2016 Database sample and import it into your SSAS project. It can help us make sure whether this issue caused by the incompatibility.

    In addition, according to the error message, there some components not installed or registered on your machine. I suggest you check whether you have installed Microsoft SQL Server Data Tools. If not, please install it from Control Panel -> Programs and Features -> Visual Studio Community 2015 -> Change -> Modify.

    If all SQL Server related components are all installed, please try repair your Visual Studio to check whether there has any installation issue on your Visual Studio.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, September 15, 2016 5:34 AM
    Moderator
  • Hi Weiwei

    I did a little more searching and chanced upon a 64-bit installation conflicting/using a 32-bit component:

    https://msdn.microsoft.com/en-gb/library/dn876712.aspx

    You can't run SSIS packages in 32-bit mode after you upgrade to SQL Server 2016 Release Candidate 1 (RC1)

    Issue and customer impact: You can't run SSIS packages in 32-bit mode after you upgrade to SQL Server 2016 Release Candidate 1 (RC1) from SQL Server 2012, SQL Server 2014, or an earlier Community Technology Preview (CTP) or Release Candidate (RC) version of SQL Server 2016. Trying to run a package in 32-bit mode fails with an unexpected exception or error. This problem occurs when you try to run a package by using the 32-bit version of dtexec.exe, and also when you try to run a package in the SSIS Catalog with the 32-bit runtime option enabled.

    This problem does not occur when you do a clean installation of SQL Server 2016 Release Candidate 1 (RC1).

    Workaround: To work around this issue, do the following things.

    1. Uninstall the earlier version of SQL Server.

    2. Do a clean installation of SQL Server 2016 Release Candidate 1 (RC1).

    3. Install the latest version of the SQL Server Data Tools (SSDT). To get SSDT,

    I had SS2008R2 installed which i took off after i'd installed SS2016.  So i took all instances of SS components off using control panel and then did a clean install of SS2016.  Everything is now working fine.

    Thanks for taking the time to respond to my original message.

    Regards

    David H-M

    Thursday, September 15, 2016 11:51 AM
  • Hi David H-M,

    I'm glad that you have resolved your issue and thanks for sharing your detailed solution here.

    Please mark your reply as answer which is benefit to other communities who has the same issue. If any question about Visual Studio IDE in future, please feel free to come back.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, September 16, 2016 5:48 AM
    Moderator