locked
Razor intellisense and syntax highlighting broken in VS2015 Community RTM RRS feed

  • Question

  • User1541448578 posted

    I have tried deleting the .sui, using the /ResetUserData flag, uninstalling and reinstalling VS2015, uninstalling every Visual Studio version and reinstalling VS2015, but no matter what I do, my Razor views are broken for editing. @model isn't highlighted in yellow. ViewBag has a red squiggly line under it. The Razor editor almost acts like a plain HTML edit. Only the @ and @{} get yellow highlighting, but there doesn't seem to be any knowledge of C# in the @ code.

    How can I fix this? This is the feature that is the main part of my job.

    Sunday, July 26, 2015 9:47 AM

Answers

  • User-166373564 posted

    Hi,

    Please try this command: Devenv.exe /ResetSettings. It restores the IDE's default settings, optionally resets to the specified VSSettings file.

    Please let me know if there is anything that I can do to help.

    With regards,

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, August 2, 2015 11:03 PM

All replies

  • User-1883873609 posted

    Someone please have a look this issue, happened to me as well. 

    Sunday, July 26, 2015 7:31 PM
  • User-166373564 posted

    Hi,

    Please try this command: Devenv.exe /ResetSettings. It restores the IDE's default settings, optionally resets to the specified VSSettings file.

    Please let me know if there is anything that I can do to help.

    With regards,

    Angie

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, August 2, 2015 11:03 PM
  • User-2125814816 posted

    Devenv.exe /ResetSettings didn't solve it for me, but Devenv.exe /resetuserdata does - however, this requires you to reinstall all extensions :-(

    Friday, August 7, 2015 2:48 AM