Universal Windows Phone 8.1 App crashes when scrolling too fast in WebView

All replies

  • Hi Piotr,

    Could it be a JavaScript exception?

    Let's do something with the Visual Studio configuration, uncheck the "Script", let's see if the problem can be fixed.


    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Friday, August 22, 2014 10:11 AM
  • Hi.

    I am experiencing the same problem.

    This has nothing to do with JavaScript, as it also crashes without any scripts running.

    The error is clearly reproduceable on a real device (as seen in the stackoverflow question).

    It does not only occur with the attached debugger, but also in release mode and when published to the store!

    And it does happen when using NavigateToString and also NavigateToLocalStreamUri.

    And it does not depend on the HTML, as it happens for custom HTML (tried a lot of it) and for remote URIs too.

    This is a platform-bug imho!

    Friday, August 22, 2014 1:55 PM
  • As I wrote in the Other thread as well, I have the exact same problem but I'm sure it's not related to the scrolling speed... maybe it could be related to the timing of the beginning of the scroll.

    Let's say that if I let the page "rest" for a while after the LoadCompleted event, then I can scroll with no problems.

    It happens on a real device (Lumia 928).

    I'm experiencing other issues too launching  InternetExplorer through the LaunchUriAsync instead of a page with just a WebView in it: going back to the app from IE crashes the app without an UnhadledExpception, without any exceptions in the lifecycle code, or wherever else.
    The debugger remains attached to a process not visible on the device anymore. In the process tab in VS2013 I can still see the entry in a running state even if it disappeared from the device.

    Friday, August 22, 2014 2:06 PM
  • Is this on a device with the Windows Phone 8.1 Update 1 Dev Preview on it? If so, it may be a known bug I reported to Microsoft several weeks ago. There's a crash in DirectManipulation on MinUser which affects all WinRT 8.1 apps on the current Update 1 dev preview release. I suspect it also affects whatever Update 1 build is apparently shipping on the new HTC M8.

    I'm told that Microsoft has a fix and that it's scheduled to ship in their next QFE update, but I wasn't given a timeline for that to happen.

    To find out if it is this issue, just run with a native debugger attached, and see if you get an AV (access violation) with just minuser.dll and DirectManipulation.dll on the stack.

    Friday, August 22, 2014 4:03 PM
  • Thanks for the hint, Brandon.

    I've debugged the native code and it really did raise an Access Violation Exc.

    First-chance exception at 0x76916E0F (MINUSER.DLL) in Poki.WindowsPhone.exe: 0xC0000005: Access violation reading location 0x00000010.
    VERIFIER STOP 00000013: pid 0xF28: First chance access violation for current stack trace. 
    	00000010 : Invalid address causing the exception.
    	76916E0F : Code address executing the invalid access.
    	0D19FCC0 : Exception record.
    	0D19FB20 : Context record.
    This verifier stop is continuable.
    After debugging it use `go' to continue.
    Poki.WindowsPhone.exe has triggered a breakpoint.

    Friday, August 22, 2014 4:23 PM
  • Any ideas for temporary workaround?

    We tried to delay page show, waiting for full page load, but currently no luck.

    Saturday, August 23, 2014 11:57 AM
  • Maybe we can merge our topics it's the exact same problem (the stackoverflow is also my topic)

    Thursday, August 28, 2014 9:22 PM
  • Switched to the other thread, thanks ;-)
    Friday, August 29, 2014 9:22 AM