none
Skype for Business - No SSO with Azure AD Connect & Seamless SSO RRS feed

  • Question

  • Any idea what could be wrong with Skype for Business because it won't work with SSO? It's always prompting for credentials. Office, Outlook etc. works nicely with SSO but SfB doesn't.
    Tuesday, July 23, 2019 4:46 PM

Answers

  • I was able to figure it out. Modern authentication was not enabled from Office 365 to Skype for Business. Once enabled SSO started to work.
    • Marked as answer by DamonWH Sunday, August 4, 2019 5:04 AM
    Sunday, August 4, 2019 5:04 AM

All replies

  • Skype for Business does not do SSO with AD Connect. It is one of the few apps that does not. 

    Since Skype for Business is being deprecated soon, I would highly recommend switching to Teams.

    https://docs.microsoft.com/en-us/MicrosoftTeams/upgrade-start-here


    Please take a moment to "Mark as Answer" and/or "Vote as Helpful" wherever applicable. Thanks!

    Tuesday, July 23, 2019 7:36 PM
    Moderator
  • This cannot be true. I have perfectly working SSO with SfB currently in my lab environment. There is Azure AD Connect & Seamless SSO and all I need to do is launch SfB and there is zero prompts.
    Wednesday, July 24, 2019 7:36 AM
  • Hi Damon,

    My apologies. I got the wrong information from someone that it had been discontinued. 

    Have you checked out this blog

    A lot of people have been able to resolve this issue following the steps here. 

    Are the user tokens are stored correctly but that they need to click an extra time to sign in, or is the SSO not working at all? Which guide are you following?


    Please take a moment to "Mark as Answer" and/or "Vote as Helpful" wherever applicable. Thanks!

    Thursday, July 25, 2019 12:06 AM
    Moderator
  • I was able to figure it out. Modern authentication was not enabled from Office 365 to Skype for Business. Once enabled SSO started to work.
    • Marked as answer by DamonWH Sunday, August 4, 2019 5:04 AM
    Sunday, August 4, 2019 5:04 AM
  • Once you enabled modern auth for SfB, how long before it started to work?
    Monday, September 16, 2019 8:44 PM