none
Net Framework 3.5 SP1 Install Problem RRS feed

  • Question

  • I have been trying to install Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update for .NET versions 2.0 through 3.5 (KB951847) x86 (that description was taken from either Windows Installer or the Windows Update site) on my wife's computer. She has an XP Home Media Center Edition OS. The only error code I have received was 0x643 which the Knowlege Base indicates is a generic error code. I have uploaded the vslogs.cab in my SkyDrive Public Folder http://cid-0d20d07344c96b21.skydrive.live.com/summary.aspx?sa=149003325 and had also tried clearing my temp files (%temp%) but was unable as I got a write protect error. When I tried installing it on my computer, I had no problem (XP Home).

    I would appreciate any help you can provide me as I have tried everything I could, which included what the Knowlege Database suggested.
    Wednesday, September 30, 2009 5:17 PM

Answers

  • Hi Tim,

    Thank you for your post.

    For .NET Framework 3.5 SP1 installation, we should upgrade XP Home Media Center Edition to SP2.
    Please check: System requirements for .NET 3.5.
    And please run the .NET Framework installer with Administrator Privilege.

    I looked into the log files and found the following log snippet in dd_NET_Framework20_Setup*.txt:

    09/29/09 22:52:56 DDSet_Error: Failed to install assembly C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\AspNetMMCExt.dll. IAssemblyCache->InstallAssembly() returned -2146234105.
    09/29/09 22:52:56 DDSet_Error: Failed to install assembly 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\AspNetMMCExt.dll' because of system error: 0x80131107
    09/29/09 22:52:56 DDSet_Status: Sleeping 100ms...
    09/29/09 22:52:56 DDSet_Error: Failed to install assembly C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\AspNetMMCExt.dll. IAssemblyCache->InstallAssembly() returned -2146234105.
    09/29/09 22:52:56 DDSet_Error: Failed to install assembly 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\AspNetMMCExt.dll' because of system error: 0x80131107
    09/29/09 22:52:56 DDSet_Status: Sleeping 100ms...
    09/29/09 22:52:56 DDSet_Error: Failed to install assembly C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\AspNetMMCExt.dll. IAssemblyCache->InstallAssembly() returned -2146234105.
    09/29/09 22:52:56 DDSet_Error: Failed to install assembly 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\AspNetMMCExt.dll' because of system error: 0x80131107
    09/29/09 22:52:56 DDSet_Status: Sleeping 100ms...

    Based on the log files, it indicates that the installer failed when it tried to install assembly AspNetMMCExt.dll.

    For this scenario, I would suggest you to try the following steps:
    - Use Cleanup Tool to remove .NET Framework 2.0, 3.0 and 3.5 on your machine
    - Manually download .NET Framework 3.5 Service Pack 1 (Full Package) and install it
    - If any issue during the installation, please try collecting log files and upload Vslog.cab file again.

    Another alternative way is to rename the existing mscoree.dll in system32 before the installation.

    Hope this helps! If you have any concern, please feel free to let me know. :)

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by Tim Shehan Saturday, October 3, 2009 7:21 AM
    Friday, October 2, 2009 8:11 AM

All replies

  • Hi Tim,

    Thank you for your post.

    For .NET Framework 3.5 SP1 installation, we should upgrade XP Home Media Center Edition to SP2.
    Please check: System requirements for .NET 3.5.
    And please run the .NET Framework installer with Administrator Privilege.

    I looked into the log files and found the following log snippet in dd_NET_Framework20_Setup*.txt:

    09/29/09 22:52:56 DDSet_Error: Failed to install assembly C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\AspNetMMCExt.dll. IAssemblyCache->InstallAssembly() returned -2146234105.
    09/29/09 22:52:56 DDSet_Error: Failed to install assembly 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\AspNetMMCExt.dll' because of system error: 0x80131107
    09/29/09 22:52:56 DDSet_Status: Sleeping 100ms...
    09/29/09 22:52:56 DDSet_Error: Failed to install assembly C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\AspNetMMCExt.dll. IAssemblyCache->InstallAssembly() returned -2146234105.
    09/29/09 22:52:56 DDSet_Error: Failed to install assembly 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\AspNetMMCExt.dll' because of system error: 0x80131107
    09/29/09 22:52:56 DDSet_Status: Sleeping 100ms...
    09/29/09 22:52:56 DDSet_Error: Failed to install assembly C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\AspNetMMCExt.dll. IAssemblyCache->InstallAssembly() returned -2146234105.
    09/29/09 22:52:56 DDSet_Error: Failed to install assembly 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\AspNetMMCExt.dll' because of system error: 0x80131107
    09/29/09 22:52:56 DDSet_Status: Sleeping 100ms...

    Based on the log files, it indicates that the installer failed when it tried to install assembly AspNetMMCExt.dll.

    For this scenario, I would suggest you to try the following steps:
    - Use Cleanup Tool to remove .NET Framework 2.0, 3.0 and 3.5 on your machine
    - Manually download .NET Framework 3.5 Service Pack 1 (Full Package) and install it
    - If any issue during the installation, please try collecting log files and upload Vslog.cab file again.

    Another alternative way is to rename the existing mscoree.dll in system32 before the installation.

    Hope this helps! If you have any concern, please feel free to let me know. :)

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by Tim Shehan Saturday, October 3, 2009 7:21 AM
    Friday, October 2, 2009 8:11 AM
  • Hello Yichun,

    Reading your post I noticed that I had left one piece of info out. My wife's computer does have SP3 installed, so the note to upgrade to SP2 became moot!

    I downloaded and ran the cleanup tool and it went fine. I then downloaded and installed the Net Framework 3.5 SP1 and it also went fine. I double checked the installed programs and it does show 3.0 SP2 and 3.5 SP1 installed, so all appears well. Thank you very much.
    Saturday, October 3, 2009 7:29 AM
  • Hi Tim,

    It's my pleasure. :)

    I'm so glad to hear that. Cheer!

    Have a good week.

    Best regards,
    Yichun Chen
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    Tuesday, October 6, 2009 3:31 AM