locked
Login failed for user 'sa'. RRS feed

  • Question

  • On task 111 out of 124 it fails to logon to sqlvm with sa.

    Is there a default sa that it tries with or what?

    Report-Progress : The Microsoft Azure Stack POC deployment failed.
    Exception calling "Open" with "0" argument(s): "Login failed for user 'sa'."
        + CategoryInfo          : NotSpecified: (:) [Invoke-Command], MethodInvoca
       tionException
        + FullyQualifiedErrorId : SqlException,Microsoft.PowerShell.Commands.Invok
       eCommandCommand
        + PSComputerName        : localhost

    Invoke-AzureStackInstaller : Some component configuration fails. Please check o
    utput for details.
    At F:\AzureStackInstaller\PoCAzureStackServicesInstaller\Microsoft.AzureStackIn
    staller.Master.ps1:1052 char:1
    + Invoke-AzureStackInstaller -SettingsXml $SettingsXml -DeploymentCrede ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorExcep
       tion
        + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorExceptio
       n,Invoke-AzureStackInstaller
    Start-PocAzureStackServicesInstallerTasks : POCAzureStackServicesInstaller fail
    ed because the following tasks failed: sql
    At C:\ProgramData\Microsoft\AzureStack\Deployment\RunAzureStackDeploymentTask.p
    s1:158 char:19
    + ...        $result = & "Start-$moduleName`Tasks" -StatusUpdatedCallback {
    +                      ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorExcep
       tion
        + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorExceptio
       n,Start-PocAzureStackServicesInstallerTasks
    At C:\ProgramData\Microsoft\AzureStack\Deployment\Get-AzureStackDeploymentStatus.ps1:107 char:15
    +     $Result = Report-Progress($status)
    +               ~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Write-Error], WriteErrorException
        + FullyQualifiedErrorId : Microsoft.PowerShell.Commands.WriteErrorException,Report-Progress

    Joakim

    Tuesday, February 23, 2016 7:52 PM

All replies

  • Hi Joakim, Could you collect the deployment logs by running Invoke-DeploymentLogCollection.ps1 from <mounted
    drive letter>:\AzureStackInstaller\PoCDeployment\ . The logs will be collected to C:\LogCollection\<GUID>. Please contact ascustfeedbackmicrosoftdotcom and we will set up a share that you can upload the logs to.

    I am also checking with the team to see if there is anything obvious to check for that could cause this failure during deployment.

    Thursday, February 25, 2016 12:02 AM
  • I think Joakim found out that he were using a " in the administrator password, when he removed that it's working.

    Saturday, February 27, 2016 9:54 AM