locked
Setup Fails on all Expression Products + Designer not working RRS feed

  • Question

  • Hi!

    I downloaded the install for Expression Blend 2 Trial ("Blend_Trial_en.exe") from MS site and when installing it I get the following errors right after the file extraction:

    First popup says the usual "Microsoft Expression Setup has encountered a problem and needs to close. We are sorry for the inconvenience."

    Second one is the interesting one. It says:
    Exception has been thrown by the target of an invocation.Cannot convert string
    'pack://application:,,,/XSetupUI:component/Resources/Icons/Setup.ico' in attribute 'Icon' to object of type 'system.windows.media.imagesource'.
    No imaging component suitable to complete this operation was found. Error at object 'XSetupUI_InitializationWindow' in markup file
    'XSetupUI;component/initializationwindow.xaml'.

    I redownloaded the install file and the same thing happened again. I then tried downloading and installing Expression Studio 2 Trial ("ExpressionStudio_Trial_en.exe") and guess what - exact same error after file extraction.

    The next logical steps were (executed in this order):

    1) Uninstalled ALL .NET versions on my PC as well as ALL Visual Studio versions I had on my machine (I had VS2000, VS2005 and VS2008 installed).

    2) I then reinstalled in the following order

    2.1) net 2.0
    2.2) net 2.0 sp1
    2.3) net 3.0
    2.4) net 3.0 sp1
    2.5) net 3.5 sp1
    2.6) Visual Studio 2008
    2.7) SP1 for VS2008

    After all this (which took me the biggest part of a day) the exact same error still occurred when trying to install Blend.

    I think its important to also mention since it could very well be linked to this problem - my WPF designer in VS2008 is also not working at all. When loading a xaml page (in WPF application or in new silverlight application) the xaml design view is just blank. It says loading then goes blank. After that its impossible to interact with the designer at all. Cannot drop or draw any controls onto it and it doesnt even respond to a right-click on the designer. However, when I create a xaml page using the code window only, I am able to build and run the application and it works fine, but the designer stays blank, whether there is code or not.

    As you can very well imagine, these issues makes it impossible for me to try and attempt starting any new projects using either silverlight or wpf - and thats a darn shame! Please HELP!!!!

    Danie Spreeth

    Thursday, October 30, 2008 4:17 PM

All replies

  • 5 days and no comments from anyone? The view counter also shows only 1 view, and that was me after I posted the thread!

    How long does one normally wait to be helped? one week? 2 weeks? more?
    Tuesday, November 4, 2008 2:54 AM
  • Hello Danie,

    Thank you for your feedback. If you are using Internet Explorer, we would like you to try clearing your IE cache.

    Since you have tried installing Blend, there is a chance that you have Blend bits sitting in your Windows\Installer cache. Please try the following:

    cd %windir%\installer

    for /f %i in (‘findstr /i /m /c:”Microsoft Expression” *.msi’) do (start /wait msiexec.exe -x %i -qn)

    When downloading Microsoft Exoression Blend, try the save option and then launch setup.exe.

    If you still see the same issue, could you please send us the log.

    Thanks,

    Anupama Tuli

    Microsoft Expression Blend

    Wednesday, January 28, 2009 11:10 PM
  • I have the same issue. I already run the cd and for command as instructed but it didn't resolve the issue.

    Where I can find the log you are mentioning?
    Saturday, May 16, 2009 5:19 PM
  • Hello Danie,

    Thank you for your feedback. If you are using Internet Explorer, we would like you to try clearing your IE cache.

    Since you have tried installing Blend, there is a chance that you have Blend bits sitting in your Windows\Installer cache. Please try the following:

    cd %windir%\installer

    for /f %i in (‘findstr /i /m /c:”Microsoft Expression” *.msi’) do (start /wait msiexec.exe -x %i -qn)

    When downloading Microsoft Exoression Blend, try the save option and then launch setup.exe.

    If you still see the same issue, could you please send us the log.

    Thanks,

    Anupama Tuli

    Microsoft Expression Blend


    We installed Expression Studio 2 Standard Edition this January. I installed VS 2008 SP1 and Silverlight Tools a couple of days ago. Because, I couldn't see xaml page in design view. I tried to open it in expression blend by clicking Open in Expression blend in Solution Explorer. My VS 2008 was hung. Then, I tried to reinstall the whole package again. I received the same error. I also ran what Anupama suggested. I received another error message "('finderstr was unexpected at this time. This is really frustrated. Please help.
    Sunday, May 24, 2009 9:43 PM
  • I also get the error similar to this ...
    Exception has been thrown by the target of an invocation.Cannot convert string
    'pack://application:,,,/XSetupUI:component/Resources/Icons/Setup.ico' in attribute 'Icon' to object of type 'system.windows.media.imagesource'.

    I get the error in VS IDE at runtime after adding a new icon to resources.  I don't care for this new syntax which seems to be causing mass confusion and unnecessary bugs in the forums I've been to.
    Wednesday, May 27, 2009 2:36 PM