none
Application Insight for Cloud Services RRS feed

  • Question

  • Hi,

    I recently added the App Insight SDK to our Cloud Service app.  Before deployment, I added the Instrumentation Key to each of the roles (1 web and 3 worker roles) defined in my .cscfg.  After the deployment, I only see only one worker role show up under Live Stream page.  So where are all my other roles?  The dashboard shows flat line for most of the charts.  So what am I doing wrong?  

    Thanks in advance.

    Wednesday, June 19, 2019 9:38 PM

All replies

  • Did you follow the guide we have on setting up App Insights for Cloud Services? 

    https://docs.microsoft.com/en-us/azure/azure-monitor/app/cloudservices

    It does display how to add the keys to each role. I assume you followed it but figured it is good to check.

    What metrics are you looking to capture? 

    Wednesday, June 19, 2019 10:04 PM
    Moderator
  • Thanks for the comment Micah.  My Cloud Services came in a package with the SDK all included by our developer.  I just need to add the Instrumentation Key to the configuration file's (.cscfg) property as shown below:

    <Setting name="APPINSIGHTS_INSTRUMENTATIONKEY" value="APP INSIGHT KEY" />

    According to the your link, I do see mentioning of creating an App Insight resource for each role.  If I have four roles, I would need to create for App Insights? 

    Thanks

    Wednesday, June 19, 2019 10:16 PM
  • You should be able to push the data to a single application insights. I see you can separate them but personally I don't believe that is needed. Regardless, yes you need to have an App Insights in place to push the data to. Otherwise, the only date you will see, such as you are likely seeing now is the one with the worker node as it is showing the data for the underlying VM. 

    So if you create an App Insights you should be able to take the Key and plug it into your code, deploy the cloud service and after a few mins you should start to see data flowing in. 

    Wednesday, June 19, 2019 11:34 PM
    Moderator
  • Thanks.  Unfortunately, only one of my roles appears to show data while the rest are not.  When I go to Live Metrics Stream, I I see "Not available: your app is offline or using an older SDK".  Application Map said "No Data".  Double checked the key and all seem right.  Don't get it.
    Thursday, June 20, 2019 12:17 AM
  • Interesting. Could you send me your Azure SubscriptionID and link to this thread to AzCommunity@microsoft.com

    I can enable your subscription for a free support request to have this looked into further. 

    Thursday, June 20, 2019 6:00 PM
    Moderator
  • Thanks.  Sent.
    Thursday, June 20, 2019 9:16 PM
  • Any update on this issue? 
    Tuesday, July 9, 2019 5:57 PM
    Moderator
  • Still being worked on....119062021003066.  As far as I know, there are some challenges.
    Tuesday, July 9, 2019 6:40 PM
  • Thanks for that. I took a look and am following the ticket. Will chime in where I can. 
    Tuesday, July 9, 2019 7:37 PM
    Moderator