locked
IISMANAGER_ERROR_LOADING_PROVIDER_TYPE RRS feed

  • Question

  • User733743779 posted

    Hello All--

    Anyone have any thoughts as to how to get around this?  It appears to be benign in that I'm not seeing a negative impact on Production, but these alerts are constant any time that IIS Manager is opened:

    IISMANAGER_ERROR_LOADING_PROVIDER_TYPE

     

    IIS Manager could not load type 'Microsoft.Web.Management.Packaging.PackagingModuleProvider, Microsoft.Web.Management.Packaging.Server, Version=7.1.1.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35' for module provider 'Packaging' that is declared in %windir%\system32\inetsrv\config\administration.config. Verify that the type is correct, and that the assembly that contains the module provider is in the Global Assembly Cache (GAC).

     

    Exception:System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.Web.Management.Packaging.Server, Version=7.1.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies. The system cannot find the file specified.

    File name: 'Microsoft.Web.Management.Packaging.Server, Version=7.1.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'

       at System.RuntimeTypeHandle._GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark, Boolean loadTypeFromPartialName)

       at System.RuntimeTypeHandle.GetTypeByName(String name, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark)

       at System.RuntimeType.PrivateGetType(String typeName, Boolean throwOnError, Boolean ignoreCase, Boolean reflectionOnly, StackCrawlMark& stackMark)

       at System.Type.GetType(String typeName, Boolean throwOnError)

       at Microsoft.Web.Management.Server.AdministrationModuleProvider.GetModuleProvider(String userName, String connectionName)

     

    WRN: Assembly binding logging is turned OFF.

    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.

    Note: There is some performance penalty associated with assembly bind failure logging.

    Is it possible to REM just this part out of the application.config?

     

    Thanks

    -RL

    Wednesday, April 29, 2009 11:12 AM

Answers

  • User733743779 posted

    Thanks for the input.

    After some Google-Fu and digging, I did find the assembly was present in %windir%\assembly and after checking the GAC, it was there too.  All very odd given the behavior.  Ultimately it was the removal from administration.config that was the solution.

     --RL

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, May 1, 2009 10:37 AM

All replies

  • User1597079171 posted

    This indicates you have IIS 7 administration pack installed, however the assembly was missed from GAC.

    Please check if you have the assembly required under %windir%\assembly. This assembly is installed by the admin pack. So, reinstall this pack should be resolve this problem.

    http://www.iis.net/downloads/default.aspx?tabid=34&g=6&i=1682

    Or you can delete the related item in your %windir%\system32\inetsrv\config\administration.config

     

    Thursday, April 30, 2009 7:12 PM
  • User733743779 posted

    Thanks for the input.

    After some Google-Fu and digging, I did find the assembly was present in %windir%\assembly and after checking the GAC, it was there too.  All very odd given the behavior.  Ultimately it was the removal from administration.config that was the solution.

     --RL

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, May 1, 2009 10:37 AM