none
HLK 10 running Validate WFP seems to hang on WFPLogo.exe RRS feed

  • Question

  • Hi,

    Why is WFPLogo.exe hanging for the Validate WFP test?

    I setup HLK 10 on Windows Server 2016 for controller and test server.  I scheduled tasks for my WFP driver and the first two suites completed successfully.  However, the WindowsFilteringPlatform_tests hands on Validated WFPUsage and it seems to be running:

    WFPLogo.Exe -t "\ArchitecturalDesign\Validate.WFPUsage" -l Filter.Driver.WindowsFilteringPlatform.ArchitecturalDesign.Validate.WFPUsage.NTLog -r

    When I run this locally, the tool opens a file with a series of questions for me to fill out and save.   I don't quite know how to configure my HLK studio project so it already has the information so they system doesn't halt.   

    I hope that if I save once then it updates config across the entire machine so I can then rerun the suite and get past this hangup.  If that fails, I guess, I can try to login as the test user and run the test.  Since the test must run as elevated admin and I performed the config as that user, I might be ok?   

    This still seems wrong, I'd expect to configure this in the project.

    Am I missing a step on the HLK setup and project configuration?

    Thanks

    Eva


    • Edited by Eva Brigid Friday, February 9, 2018 5:18 PM
    Friday, February 9, 2018 3:17 PM

Answers

  • Hi me,

    On HLK controller the default WFPLogo.info files in 

    C:\Program Files (x86)\Windows Kits\10\Hardware Lab Kit\Tests

      amd64\nttest\NetTest\SecureNet\WFPTest

    and

      x86\nttest\NetTest\SecureNet\WFPTest

    need to be replace with your customized version.  At least this seems to have worked in my case.

    and 
    • "UseAnswerFile = 1" in WFPLogo.info
    • Marked as answer by Eva Brigid Tuesday, February 13, 2018 11:10 PM
    • Edited by Eva Brigid Wednesday, February 21, 2018 3:46 PM
    Tuesday, February 13, 2018 11:10 PM