locked
Windows App Certification Kit won't run.

    Question

  • I'm trying to submit a Windows Store App but have been unable to get the certification kit to run. I've followed the steps others have used to resolve the issues but have not had any success.

    1. I reinstalled Windows. I'm running Windows 8.1 Pro Preview inside VMWare Player. I spun up a new VM, did a fresh install with a brand new Hotmail account and Visual Studio install.

    2. The Get-AppXPackage trick doesn't work. The output is here: http://pastebin.com/ytVJrLBb. You can see all InstallLocations are populated (and I even verified they are all valid). You can also see my app is installed.

    3. Tried to verify from within Visual Studio Express 2012 via the "Store > Create App Packages..." menu option. I updated both the Windows App Certification Kit and SDK during this step. I get an error message that reads "The {0} cannot continue testing since the specified windows store app was not found. Please verify that the packagefullname is correct."

    4. Tried to run "Windows App Cert Kit" from the start menu. I get a completely empty app list. 

    5. Run the command line using the packagefullname I got from step 2. `appcert.exe test -apptype windowsstoreapp –packagefullname 27303JoshDuck.BabyPlayAnimalSounds_1.0.0.11_neutral__dmsa69vbn9vt6 -reportoutputpath C:\Users\Joshua\Desktop\out.xml`
    I get the error message: "A valid package full name must be specified."

    Any help is greatly appreciated. I've already wasted hours on this. The app submission process says the certification failed, but doesn't give actual output so I have no way of moving foward.
    Monday, August 12, 2013 2:37 AM

Answers