none
4min logon duration each VHD disk. RRS feed

  • Question

  • Have two customers that got those problems this weekend starting Friday morning.

    Server 2016, Citrix 7.15CU4, FSlogix 2.9.7205.27375

    When users logs in they see "Waiting for FSlogix Apps service" for 241sec. Then the login continue to the ODFC part. Then the users have to wait another 240sec to finally get logged on.

    This is what we can see in the event logs:
    System logs:

    A timeout (10000 milliseconds) was reached while waiting for a transaction response from the WSearch service.

    Event: 7011

    Application logs:

    The winlogon notification subscriber <frxsvc> is taking long time to handle the notification event (StartShell).

    Event: 6005

    The winlogon notification subscriber <frxsvc> took 241 second(s) to handle the notification event (StartShell).

    Event: 6006

    FSlogix profile logs:

    [21:29:42.410][tid:00000aa0.00000448][INFO]             VHD attached

    [21:29:42.410][tid:00000aa0.00000aa4][INFO]             Volume attach event

    [21:33:42.560][tid:00000aa0.00000448][INFO]             Volume name: \\?\Volume{077b114c-1445-4a0d-87c7-5b36e80f9997}\

    [21:33:42.576][tid:00000aa0.00000448][INFO]             Profile format version 2

    FSlogix Search logs:

    [21:26:10.398][tid:00000aa0.00000e64][INFO]           ===== End Session: Windows Search Dismount

    [21:26:10.429][tid:00000aa0.00000e64][INFO]           ExportRegistry operation succeeded

    [21:26:17.680][tid:00000aa0.00000e64][INFO]           DeleteRegistry operation succeeded

    [21:33:50.279][tid:00000aa0.00000448][INFO]           ===== Begin Session: Windows Search Mount

    [21:33:50.279][tid:00000aa0.00000448][INFO]            Mount operation triggered for: S-1-5-21-839981148-1931570126-2013996557-14157

    [21:33:50.279][tid:00000aa0.00000448][INFO]            Windows Search Service status ready for mounting stage

    I have tried doing:
    Update to latest Windows updates
    Installed latest FSlogix agent (2.9.7237)
    Fallback to FSlogix 2.9.71

    Any tips appreciated!

    UPDATE (25/11 13:35):
    It is the same problem as this:
    https://social.msdn.microsoft.com/Forums/windowsserver/en-US/c6bbf232-6034-4dc8-9531-0fc9f5de78e2/windows-defender-scan-on-login-the-fslogix-vhd?forum=FSLogix

    • Edited by Mr.Ecke Monday, November 25, 2019 12:35 PM
    Monday, November 25, 2019 10:28 AM

Answers

  • Hello, we have just received the following update:

    Signature version 1.305.2813.0 was published about 1 hour ago and should address this issue – and clients will update automatically in the next 24 hours. Impacted users can force an update (either from WU or from WD UX (or via manageability interfaces)). Please report if issues are still being seen with this version.

    Regards,

    Brent
    Monday, November 25, 2019 11:28 PM
    Owner

All replies

  • We're experiencing the same problems!

    Since when are you experiencing these problems? For us it started on 22-11.

    The only difference is that we're not using FSLogix or Citrix.

    Currently we're looking into Windows Defender. Since that is the only software that updates during the day.

    Monday, November 25, 2019 11:25 AM
  • is a defender problem see https://social.msdn.microsoft.com/Forums/windowsserver/en-US/c6bbf232-6034-4dc8-9531-0fc9f5de78e2/windows-defender-scan-on-login-the-fslogix-vhd?forum=FSLogix


    Thomas Lauer

    Yes, we found that it was that problem aswell. Turning of realtime defender is not so good to do i hope they have a fix for this soon.
    Monday, November 25, 2019 12:33 PM
  • We have the same issue since friday.
    Monday, November 25, 2019 12:55 PM
  • We have similar problems as mentioned in this thread, (Server 2016, Citrix VAD 1811, Citrix User Profile Management and FSLogix for O365 Containers). We also have F-Secure as primary AV.

    When users logon, (since friday november 22), they get the infamous "Black Screen" for up to ten minutes before properly logged on.

    As mentioned earlier in this thread, the problem was with Windows Defender and Real Time Scan of the users VHD-files at logon.

    Ran Set-MpPreference -DisableRealtimeMonitoring $true to test disable the Real Time Scanning and whoops, logon went back to normal again!

    So now we are uninstalling Windows Defender features on the affected servers and hopefully we are soon back to business as usual again:)


    • Edited by fzita Monday, November 25, 2019 12:58 PM
    Monday, November 25, 2019 12:58 PM
  • Nothing useful here, just reporting in that we are having the same problem.
    Monday, November 25, 2019 5:48 PM
  • Have two customers that got those problems this weekend starting Friday morning.

    Server 2016, Citrix 7.15CU4, FSlogix 2.9.7205.27375

    When users logs in they see "Waiting for FSlogix Apps service" for 241sec. Then the login continue to the ODFC part. Then the users have to wait another 240sec to finally get logged on.

    This is what we can see in the event logs:
    System logs:

    A timeout (10000 milliseconds) was reached while waiting for a transaction response from the WSearch service.

    Event: 7011

    Application logs:

    The winlogon notification subscriber <frxsvc> is taking long time to handle the notification event (StartShell).

    Event: 6005

    The winlogon notification subscriber <frxsvc> took 241 second(s) to handle the notification event (StartShell).

    Event: 6006

    FSlogix profile logs:

    [21:29:42.410][tid:00000aa0.00000448][INFO]             VHD attached

    [21:29:42.410][tid:00000aa0.00000aa4][INFO]             Volume attach event

    [21:33:42.560][tid:00000aa0.00000448][INFO]             Volume name: \\?\Volume{077b114c-1445-4a0d-87c7-5b36e80f9997}\

    [21:33:42.576][tid:00000aa0.00000448][INFO]             Profile format version 2

    FSlogix Search logs:

    [21:26:10.398][tid:00000aa0.00000e64][INFO]           ===== End Session: Windows Search Dismount

    [21:26:10.429][tid:00000aa0.00000e64][INFO]           ExportRegistry operation succeeded

    [21:26:17.680][tid:00000aa0.00000e64][INFO]           DeleteRegistry operation succeeded

    [21:33:50.279][tid:00000aa0.00000448][INFO]           ===== Begin Session: Windows Search Mount

    [21:33:50.279][tid:00000aa0.00000448][INFO]            Mount operation triggered for: S-1-5-21-839981148-1931570126-2013996557-14157

    [21:33:50.279][tid:00000aa0.00000448][INFO]            Windows Search Service status ready for mounting stage

    I have tried doing:
    Update to latest Windows updates
    Installed latest FSlogix agent (2.9.7237)
    Fallback to FSlogix 2.9.71

    Any tips appreciated!

    UPDATE (25/11 13:35):
    It is the same problem as this:
    https://social.msdn.microsoft.com/Forums/windowsserver/en-US/c6bbf232-6034-4dc8-9531-0fc9f5de78e2/windows-defender-scan-on-login-the-fslogix-vhd?forum=FSLogix

    We are currently working with the Windows Defender team to understand this issue, and drive to resolution.  Right now this appears to have been caused by a definitions update in defender.  I will update when I know more from them.
    Monday, November 25, 2019 7:09 PM
  • Hello, we have just received the following update:

    Signature version 1.305.2813.0 was published about 1 hour ago and should address this issue – and clients will update automatically in the next 24 hours. Impacted users can force an update (either from WU or from WD UX (or via manageability interfaces)). Please report if issues are still being seen with this version.

    Regards,

    Brent
    Monday, November 25, 2019 11:28 PM
    Owner