none
App insights map ignores cloud role name RRS feed

  • Question

  • Went ahead and installed a TelemetryInitializer that sets Cloud Role name and instance to a value. I see these properties show up with each trace. Problem is that the Application Map never takes the new values into account and the diagram is incomplete.

    Any ideas as to what I should check here?

    Thanks


    Travis

    Monday, April 20, 2020 1:33 PM

All replies

  • Hi, Travis!

    I went through our documentation and created a quick ASP.NET app.  When I go to the Application Map, I see the custom cloud role name as expected:

    https://docs.microsoft.com/en-us/azure/azure-monitor/app/app-map?tabs=net

     

    To troubleshoot the Application Map, the documentation has some recommendations:

    1. Make sure you're using an officially supported SDK. Unsupported/community SDKs might not support correlation.

      Refer to this article for a list of supported SDKs.

    2. Upgrade all components to the latest SDK version.

    3. If you're using Azure Functions with C#, upgrade to Functions V2.

    4. Confirm cloud role name is correctly configured.

    5. If you're missing a dependency, make sure it's in the list of auto-collected dependencies. If not, you can still track it manually with a track dependency call.

    Additionally, be sure to look at the 10,000 node limit (or 1,000 separate ungrouped nodes) which would cause the map to be incomplete:

    https://docs.microsoft.com/en-us/azure/azure-monitor/app/app-map?tabs=net#troubleshooting

     

    If you still run into issues after going through the troubleshooting and reviewing your configuration, let us know so we can troubleshoot this further.

    Monday, April 27, 2020 7:08 PM
    Moderator
  •  Hey thanks for getting back with me. I've exhausted the docs at this point. The thing is I can see that the initializer is working. I see the correct service name being set to the Cloud Role Name for each trace I send in. It's just that the diagrams don't reflect those http request. 

    Thanks again for your effort..I really wish this thing worked..


    Travis

    Tuesday, April 28, 2020 5:12 PM
  • If you've exhausted the docs, we can try more detailed troubleshooting but we'll need to get some additional information from you directly.  Please email the following to AzCommunity@microsoft.com and we'll get back to you promptly:

     

    • Your Subscription ID (this can be found by searching for "Subscriptions" in the portal)
    • A link to this thread so we can validate and expedite the request
    • A brief, 2-3 sentence summary of your issue
    • The person you were working with (kobulloc)

     

    That would look something like this (feel free to copy and paste):

     

    I was working with kobulloc on an Application Insights issue where my custom cloud role name was not showing up in the application map.

     

    Forum Link:

    https://social.msdn.microsoft.com/Forums/en-US/eabf2df7-61a3-407a-99f9-7928b98ad965/app-insights-map-ignores-cloud-role-name?forum=ApplicationInsights

     

    Subscription ID:

    aaaaaa-bbbb-cccc-1111-222222222222

    Wednesday, April 29, 2020 12:42 AM
    Moderator