locked
Failed Nodejs Zip file deployment to a WebJob RRS feed

Answers

All replies

  • Can you check the maximum depth of the path in the zip? Unfortunately, Windows has path limitations of 260 chars, and npm modules can sometimes blow that limit.

    In Kudu, try expanding the zip (via drag n drop), and look under D:\home\LogFiles\kudu\trace for any interesting error related to the zip operation.

    Tuesday, June 2, 2015 5:35 PM
  • Have you tried uploading just the zip in the debug console (when you drag it you can place it in a box to unzip it)?

    What is the longest path you have in your WebJob files? (windows has a limitation for long paths)

    Amit

    Tuesday, June 2, 2015 5:36 PM
  • Not sure what I am looking for. There are many files like this 2015-06-02T17-45-18_0e7570_006_node.exe_0s.xml, but they all seem to be empty.

    The folder structure thing makes sense. I did try to upload folders one by one and that failed last night too. But again they could have had a nasty nesting problem. Any suggestions to fix that?


    Chris Love

    Tuesday, June 2, 2015 5:48 PM
  • Can you try uploading the WebJob zip file using the debug console?

    Also can you look in the files of your WebJob for the file with the longest path?

    Amit

    Tuesday, June 2, 2015 5:52 PM
  • This seems to be the longest path I could find:

    node_modules\request\node_modules\har-validator\node_modules\is-my-json-valid\node_modules\generate-object-property\node_modules

    Yes I tried to upload the zip file in the kudu console as well as the individual files folder by folder.


    Chris Love

    Tuesday, June 2, 2015 8:23 PM
  • It looks truncated as "node_modules" will usually have other directories in it.


    Tuesday, June 2, 2015 9:01 PM
  • oh I just did not copy the last folder there.

    Chris Love

    Tuesday, June 2, 2015 9:44 PM
  • I may have fixed it:

    So I made a new zip file after I removed the full azure node module. I changed it to just azure-storage. I also removed all the test folders from the node_modules folder per this stackoverflow question, http://stackoverflow.com/questions/26580100/azure-webjob-system-io-pathtoolongexception.

    This time is seemed to work, I even ran the job.


    Chris Love

    Monday, June 8, 2015 3:56 AM