none
Office 365 SDK for iOS not log in for Enterprise account RRS feed

  • Question

  • I am developing application using O365-iOS-Connect.I can logIn with my Ofiice 365 trial account with two factor authentication and it working properly but facing issue for Enterprise credentials it is looping within sign in page and Organisation verification page and could not even enter password(I am using iOS 10.0).

    Following steps are the scenario of problem

     - Entering Email address of Enterprise account.
     - it will automatically redirects to Company Login.
     - selecting work account.
     - Again asking for mail_id and password and this keeps repeating.

    Kindly let me know your suggestions/solution, Thanks in advance




    • Edited by Taral Rathod Wednesday, November 2, 2016 11:13 AM For Better understanding.
    Thursday, October 27, 2016 3:31 PM

All replies

  • Hi Taral, Is this a "Test account" or a "Configuration account". Why don't you also post here the steps you followed without talking about any information related to your client or your project.
    Friday, October 28, 2016 4:20 AM
  • Hi TShah,

    I have follwed following steps to create account

    Step 1: Login into https://portal.azure.com

    Step 2: Click on “New” in left top corner

    Step 3: Search for ‘Active Directory’ (It will display dropdown in which active directory is listed.)

    Step 4: Click on “Active directory” from dropdown. (It will display results related to active directory)

    Step 5: Click on “Active directory” from results. (It will display information related to active directory)

    Step 6: Scroll down on newly opened Right side window and click on “Create”

    Step 7: Above step will redirect to old azure portal and it will open dialog with Add directory title.

    Step 8: Select “Use existing directory” option from drop down list also check the check box of “I am ready to be signed out now” option and click on proceed (tick mark). (It will logout from azure and ask for login)

    Step 9: Login with your office 365 account (With Global Rights)

    Step 10: It will ask to continue with your active directory. (Note down the name of directory which is highlighted in Single quotes.) Click on “Continue

    Step 11: Click on “Sign out now”.

    Step 12: It will ask for login again. Click on “Go to the new azure portal” (It will redirect you to new portal)

    Step 13: Login with your azure account.

    Step 14: Click on “profile Icon” at right top corner.(It will open drop down with all the directory options)

    Step 15: Select directory which you noted down in Step 10. (It will select this directory as current directory).

    Step 16: Click on “Azure Active Directory” on left navigation panel.

    Step 17: Click on “App Registrations” in newly opened window.

    Step 18: Click on “Add” button in newly opened window.

    Step 19: Type application name as “APP NAME” in Name field. Select Application type as “Native“ and enter Sign-on URL as “REDIRECT URI”.Click on create button. (It will add new application in app listing)

    Step 20: Click on newly created app. Note down “APPLICATION ID

    Step 21: Go to settings-Required permissions. (It will open new window with title required permissions).

    Step 22: Click on “Add” and then click on “Select an API”. Select “Office 365 Exchange online” option from listing and click on “Select” (It will open enable access window).

    Step 23: Check “Send mail as user” check box and click on “Select” button.

    Step 24: Click on “Done” button in “Add API access” window.

    After this I have Integrated O365-iOS-Connect with my application, so I can login from my O365 Trial account and able to send mail properly. But there is some problem with Enterprise account.

    Saturday, October 29, 2016 4:14 PM