locked
Attempting to use Starter Kit with SQL Server 2005 Standard edition RRS feed

  • Question

  • User1603574069 posted

    I'm attempting to use SQL Server 2005 Standard edition as the database server for the Club Starter Kit. I've created a new database, ran the aspnet_sqlreg.exe against the new database to create the aspnet schema. I then run the aspnet configuration tool but I cannot set up roles. It does show me the number of users in the database, but when I attempt to create/manage the roles or users, I get the following error:

    An error was encountered. Please return to the previous page and try again.

    The following message may help in diagnosing the problem: An error has occurred while establishing a connection to the server. When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified) at System.Web.Administration.WebAdminPage.CallWebAdminHelperMethod(Boolean isMembership, String methodName, Object[] parameters, Type[] paramTypes) at ASP.security_roles_manageallroles_aspx.BindGrid() at ASP.security_roles_manageallroles_aspx.Page_Load() at System.Web.Util.CalliHelper.ArglessFunctionCaller(IntPtr fp, Object o) at System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) at System.Web.UI.Control.OnLoad(EventArgs e) at System.Web.UI.Control.LoadRecursive() at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

    My data connections (as well as the membership settings) are as follows:

    1    <connectionStrings>
    2        <add name="ClubSiteDB" providerName="System.Data.SqlClient"
    3          connectionString="Data Source=localhost;Initial Catalog=SBAAClub;Integrated Security=SSPI;persist security info=false;" />
    4    </connectionStrings>
    5    
    6    <membership>
    7    	<providers>
    8    		<remove name="AspNetSqlMembershipProvider"/>
    9    		<add name="AspNetSqlMembershipProvider" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="ClubSiteDB" enablePasswordRetrieval="false" enablePasswordReset="true" requiresQuestionAndAnswer="true" applicationName="/" requiresUniqueEmail="true" minRequiredPasswordLength="6" minRequiredNonalphanumericCharacters="0" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" passwordAttemptWindow="10" passwordStrengthRegularExpression=""/>
    10   	</providers>
    11   </membership>
    
     

    I've opened up ports in the firewall for the SQL Server Browser and such, ensured remote connections are allowed, etc and this still happens. 

    Any ideas?

    Thanks!

     

    Thursday, September 11, 2008 12:23 PM

Answers

  • User1603574069 posted

    Well, I figured it out after MUCH digging. I needed to set up a roleManager provider as well:

     

            <roleManager enabled="true" defaultProvider="SqlRoleProvider">
                <providers>
                    <clear/>
                    <add name="SqlRoleProvider" applicationName="/" connectionStringName="ClubSiteDB" type="System.Web.Security.SqlRoleProvider" />
                </providers>
            </roleManager>
    

     

    Now it works just fine!

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, September 11, 2008 1:53 PM