none
Kinect stopped working a week or so ago RRS feed

  • Question

  • I've been using the Kinect from the developer preview for about three or four months now without any issues. However last week when I tried using it again (without any updates to the SDK) it no longer works. Neither my applications or Kinect Studio are able to use the device. Strangely, the Kinect Configuration Verifier IS able to at least view the streams and displays one warning in the USB Controller tab about the port having an "unknown bandwidth".

    I'm not sure if this was a result of a Windows update (seems the most likely) or not, but are there any solutions to this issue or has anyone else experienced this?

    Monday, September 29, 2014 2:32 PM

All replies

  • Did you change USB ports?  Did you change hardware in any way?  (Including adding or removing other USB devices?)  Have you eliminated the obvious issues of the power supply and cabling being connected properly and in working condition?

    Did you install any other software since it last worked?

    Do you have another machine with a USB 3.0 controller that you can use to verify the health of your Kinect sensor device?

    Monday, September 29, 2014 4:36 PM
  • I tried other ports with the same results. The hardware setup hasn't changed at all which is what is confusing about the situation, along with the fact that I experienced no device failures up until this point at all. I also checked the cables and connections and everything is fine. This is further verified by the configuration tool being able to read the streams from the camera.

    As far as software changes, none have happened other than the Windows updates that tend to trickle end, which is why I suspect that. I've seen a few other people having similar issues as me and so I assume I'm also not the only one being affected.

    I'm going to try another Kinect V2 I have and see if that one is able to function. I'll also try it on another PC. It would be a shame though if the dev preview version was made a paper weight by a patch.

    Monday, September 29, 2014 4:49 PM
  • There should be know reason the device no longer works. We still have DPP users continuing to use the device without issues, but it is "pre-release" hardware. If you paid the fee, you should have received a full retail version as a replacement of the device. Does that one or a retail device you purchased exhibit the same behavior?

    The original DPP device(white/black stripes) has internal hardware fuses to protect it, one of those may have done its job, but there is no easy way to fix that.


    Carmine Sirignano - MSFT


    Monday, September 29, 2014 5:40 PM
  • I tested the newer Kinect 2 from the DPP and it works fine.

    Regarding the fuses, that may be a good lead. I'm in Orlando and there have been a few power surges the last month or so because of all the storms. What can I do to repair the other Kinect? Can I send the device back and get it fixed, or is there a way to have the part shipped to me so I can replace it?

    Tuesday, September 30, 2014 1:52 PM