locked
SSMA - Index was outside bounds of the Array RRS feed

  • Question

  • Dear Friends,

    While running SSMA for Oracle to SQL migration opportunity, I have been facing following error message. This message is generated while creating report with procedures and tables included in the schema. Oracle version is 11g without RAC.

    The error message is

    "Index was outside the bounds of the Array"

    Please let me know if anybody has faced similar issue and how it was solved.

    Thanks

    Ashwani kapoor

    • Moved by Fanny Liu Monday, May 19, 2014 1:21 AM not about ssrs
    Wednesday, May 7, 2014 7:53 AM

All replies

  • Hello,

    Based on your description, it seems that you migrate a Oracle database to SQL Server and then create a SSRS report by retrieve data with a Stored Procedure. If I have any misunderstanding, please correct me.

    Can you exec the stored procedure in SSMS without get error? Did you get this error message when preview the report and the error associated with  a value expression of a textbox? If so, please post the expression for us.

    It benefit us for further analysis if you can post more details.

    Regards,
    Fanny Liu


    Fanny Liu
    TechNet Community Support

    Thursday, May 8, 2014 7:43 AM
  • Hello Fanny,

    Thanks for your reply.

    I am just running the SSMA tool to migrate tables / Procedures from Oracle to SQL Server.  The error is popped up when I run Create report in the tool.

    Hope this provide clear understanding.

    Thanks

    Ashwani

    Monday, May 12, 2014 6:08 AM
  • Hello,

    So, your issue is not related to SQL Server Reporting Serives. You should post the question in SQL Server Migration Forum.

    Based on your description, you try to migrate table and stored procedure and tables form Oracle database to SQL Server with SSMA tool, and it report a error: "Index was outside the bounds of the Array".
    The "index out of bounds" error may occurs when the elements you refer to is not exist.
    In your case, it may related to incorrect data type convert or any complex statements not be automatically converted.

    For example, the Oracle SUBSTR() function supports negative values for character position. SUBSTR(‘TechNet’,-3,3) returns ‘Net’ in Oracle, whereas SUBSTRING(‘TechNet’,-3,3) would return an empty string in SQL Server. You should modify statements in SSMA to resolve incompatibilities manauly with SUBSTRING(@str, LEN(@str) + 1 - 3, 3).

    Please refer to the error message and warning message section on the SSMA tool. The error message should includes a link that displays the object containing the error and then you can modify the statements to correct to the error.

    Reference:http://technet.microsoft.com/en-us/magazine/hh334645.aspx

    Regards,
    Fanny Liu


    Fanny Liu
    TechNet Community Support

    • Proposed as answer by Fanny Liu Monday, May 19, 2014 1:21 AM
    Tuesday, May 13, 2014 9:44 AM