none
Outlook load time is slow when our add-ins are installed... what to do? RRS feed

  • Question

  • We have a customer that has our VSTO outlook integration add-in installed.  They have reported that Outlook is really slow to start up.   They see the Outlook splash screen for a minute more than without our integration component installed.  What can I do?   

    Thanks!

    Monday, November 12, 2012 7:24 PM

Answers

  • Don't do anything other than minimal initializations in your startup handler. Use MAPILogonComplete() or some other way of delaying your initializations until after Outlook becomes responsive.
     
    If possible, where the object model isn't involved, try to do as much initialization as possible in one or more background threads.
     
    Outlook 2013 actually monitors each addin's startup time if it's during Outlook startup, and if it delays Outlook too much the addin will be disabled.

    --
    Ken Slovak
    [MVP-Outlook]
    http://www.slovaktech.com
    Author: Professional Programming Outlook 2007
    "alexkfh" <=?utf-8?B?YWxleGtmaA==?=> wrote in message news:ea470245-14a2-4319-a675-bc9eae823fa7...

    We have a customer that has our VSTO outlook integration add-in installed.  They have reported that Outlook is really slow to start up.   They see the Outlook splash screen for a minute more than without our integration component installed.  What can I do?   

    Thanks!


    Ken Slovak MVP - Outlook
    Monday, November 12, 2012 8:59 PM
    Moderator

All replies

  • Don't do anything other than minimal initializations in your startup handler. Use MAPILogonComplete() or some other way of delaying your initializations until after Outlook becomes responsive.
     
    If possible, where the object model isn't involved, try to do as much initialization as possible in one or more background threads.
     
    Outlook 2013 actually monitors each addin's startup time if it's during Outlook startup, and if it delays Outlook too much the addin will be disabled.

    --
    Ken Slovak
    [MVP-Outlook]
    http://www.slovaktech.com
    Author: Professional Programming Outlook 2007
    "alexkfh" <=?utf-8?B?YWxleGtmaA==?=> wrote in message news:ea470245-14a2-4319-a675-bc9eae823fa7...

    We have a customer that has our VSTO outlook integration add-in installed.  They have reported that Outlook is really slow to start up.   They see the Outlook splash screen for a minute more than without our integration component installed.  What can I do?   

    Thanks!


    Ken Slovak MVP - Outlook
    Monday, November 12, 2012 8:59 PM
    Moderator
  • maybe show us your add-in startup routine

    Tuesday, November 13, 2012 9:39 AM